Bug 39358 - Images width is shrank on Microsoft Word document
Summary: Images width is shrank on Microsoft Word document
Status: RESOLVED DUPLICATE of bug 39928
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: All Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-07-18 14:36 UTC by Mr Bump
Modified: 2013-11-24 21:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
doc example (78.00 KB, application/msword)
2011-07-18 14:36 UTC, Mr Bump
Details
Original file (23.26 KB, application/vnd.oasis.opendocument.text-template)
2011-09-16 11:10 UTC, Dominique LEGER
Details
Result : Bad logo file (24.00 KB, application/msword)
2011-09-16 11:12 UTC, Dominique LEGER
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mr Bump 2011-07-18 14:36:21 UTC
Created attachment 49277 [details]
doc example

A simple doc with images, that are shrank on the width property, but not in height. Exporting to PDF causes the same issue. Microsoft Word 2007 displays and exports the file properly.
Comment 1 Jeffrey 2011-07-20 06:33:46 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux. Images in LO writer are thinner (smaller in width). It looks like the images and text are divided into different cells of a table. Perhaps Word and Writer's default handling of scaling the image is causing the problem.
Comment 2 Dominique LEGER 2011-09-16 11:10:57 UTC
Created attachment 51269 [details]
Original file
Comment 3 Dominique LEGER 2011-09-16 11:12:17 UTC
Created attachment 51271 [details]
Result : Bad logo file
Comment 4 Dominique LEGER 2011-09-16 11:13:08 UTC
I can confirm this bug, and have to say this is a high importance bug since it corrupt documents.

Tested with LO 3.4.3 at work : it is shrinking our logos!!!
We had to revert to LO 3.3

2 attachements : Charte.ott is the original file
                 Charte.doc is the result/corrupted logos file


Cheers.
Comment 5 Dominique LEGER 2011-09-16 11:17:33 UTC
I have to add :

every time I modify and save the .doc file the logo is more shrunk ...
Comment 6 Dominique LEGER 2011-09-21 15:29:27 UTC
marked platform at "all" since I'm Win 32, and original poster was win 64 bits

marked importance as "high" "normal" since LO 3.4 is now tagged as "Safe for production use by most users and enterprises"

marked component to "Writer"
Comment 7 Rainer Bielefeld Retired 2011-09-25 07:52:43 UTC
[Reproducible] with sample "Lavado, planchado y secado.doc" (others not tested) and "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". Worked fine with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]"

@dleger@free.fr
Yes, this one is concerning the same problem, thank you  for your attention!

@Mr Bump 
@dleger@free.fr
May be you can add some information concerning pictures and document creation in "Bug 39928 - VIEWING: pictures in particular .doc shown wrong, picture size correct, but contents shrunken and surrounded by white margin"?

*** This bug has been marked as a duplicate of bug 39928 ***