Bug 39407 - With IBUS input software installed, Writer prevents input of diacritics using dead keys
Summary: With IBUS input software installed, Writer prevents input of diacritics using...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-20 12:19 UTC by jdsloane
Modified: 2012-08-31 10:05 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdsloane 2011-07-20 12:19:49 UTC
I often type in Japanese, Chinese, and Korean, so I´ve installed IBUS, which makes it possible to use the input software for those languages. And I often need to type characters like ō and ü in the middle of documents that are otherwise all in English.

In MSWord I could set up simple, intuitive shortcut keys through the Insert-->Symbol menu, so that I could type them with a regular US keyboard. Libreoffice doesn´t have that function. It does seem to have workarounds like macros and the ¨Compose Special Characters¨ attachment, but those are more complex and resource-hungry tools than I need.

In Ubuntu there are two easy solutions under ¨System Preferences-->Keyboard Layout¨. Both of them use ¨dead keys¨ to type letters with diacritical marks and other special characters.

1. ¨USA - Alternative International¨, which makes it possible to type my Ū and Ö very easily using the Alt Gr (right Alt) key.

2. Designate a ¨Compose Key¨, which can be used in certain key combinations to type various kinds of characters.

Here´s the problem:

Both of these methods work fine in Libreoffice Writer, as long as IBUS isn´t installed.

With IBUS installed, they work fine in ALL OTHER APPLICATIONS. Terminal console, text editor, Firefox, file manager, and even Abiword, in both Kubuntu and Xubuntu.

But neither of these methods works in Writer if IBUS is activated. For example, when using the US Alt-Intl keyboard layout, <AltGr+-><o> gives me simply "o" instead of the "ō" that should appear. The Compose Key also stops working (in LibreOffice only). The problem in Libreoffice goes away when I uninstall IBUS, and reappears (only in LibreOffice) when I reinstall and reselect it. The dead keys get disabled as soon as IBUS is selected in the system preferences, even when I haven´t installed the input method for any particular language.

So that´s everything I know about the problem. To summarize:

IBUS + other applications => fine
no IBUS + Writer => fine
yes IBUS + Writer => no dead key input

I assume this is a bug with Libreoffice specifically, since the problem does not appear in any other application.
Comment 1 Björn Michaelsen 2011-12-23 12:25:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:01:16 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:02:22 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:06:59 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:09:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian