Bug 39411 - Writer hangs consistently during "Export to pdf" operation
Summary: Writer hangs consistently during "Export to pdf" operation
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-20 22:43 UTC by narayanaras
Modified: 2013-11-30 21:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of Process Explorer (on Windows 7) (361.07 KB, application/x-7z-compressed)
2011-07-22 01:18 UTC, narayanaras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2011-07-20 22:43:01 UTC
I have a 6 MB odt file (143 pages, A4 size). When I try to export this file to pdf, Writer hangs (becomes unresponsive).

The progress bar (at the bottom of the screen) stops at 20% progress. The mouse pointer shows hourglass.

During this entire period, the Private Bytes parameter keeps increasing LINEARLY, without leveling off, or a glitch in the graph (as seen in the Process Explorer). After a few minutes, it reached from 100 MB to 700 MB and was increasing even further, when I aborted the operation. 

(Memory leak??)

The same problem is observed on two different PCs of different makes, CPUs and OSs (Win XP and 7). Therefore it is concluded that the problem is with LibreOffice only.

I can share the odt file if required.
Comment 1 Jeffrey 2011-07-21 07:48:50 UTC
How to check for leaks? Are you using valgrind? I think it would be helpful if you attached the document, because perhaps it has to do with the magnitude of the document you are trying to export.

Looks very similar to bug 32771 (20% and all). For now I will mark as duplicate.

https://bugs.freedesktop.org/show_bug.cgi?id=32771

*** This bug has been marked as a duplicate of bug 32771 ***
Comment 2 narayanaras 2011-07-21 19:24:47 UTC
I don't think Bug 39411 is a duplicate:

1. This bug is reporting for a 64-bit system. In my case, a 32-bit LibO is used on a 32-bit OS. (In fact two different PCs are using two different flavors of Windows: XP and 7; and both PCs have exactly the same problem. 

2. While this bug describes an outright crash (LibO vanishes without warning or error box), my bug highlights that the LibO process keeps running, and keeps grabbing more and more private bytes (the curve is linear and rising). I aborted the operation at 700+ MB, but it was NOT crashing on its own. Visually, the LibO interface is visible, and shows a hourglass.

Therefore, I request that these bugs should not be marked as duplicates.

****
I can share the file, but it is not for public domain.
Please provide an email ID so that I can send it directly.

Thanks.
Comment 3 narayanaras 2011-07-21 19:28:27 UTC
@memory leak:

According to msdn, a constantly increasing private bytes is a symptom of memory leak. I have not done any further testing. But since I can make the file available, further analysis would be possible for the testers.

Thanks.
Comment 4 Jeffrey 2011-07-21 19:39:59 UTC
Sorry for the confusion. I am just here to examine some bugs, but I cannot reproduce this problem, so I would have no certainty of whether this were a duplicate or not. So your judgment is best in this situation. So if you don't think it is, then it probably isn't. Besides, you pointed out some very valid reasons. 

Could you possibly attach your document? I want to try exporting it to see if it is reproducible, so I can isolate the problem to having to do with the attributes of your file. Thanks.
Comment 5 narayanaras 2011-07-21 21:20:07 UTC
As I mentioned, the file is not for public domain. So I can share it with you if you can provide an email ID. Alternatively, I can provide a URL, from where you can download it directly.

BTW this file (and another one just like it but with 280 pages) are basis for 4 different bugs I have filed so far. So both files need to be examined for the other bugs too. 

I would prefer that the files are taken and placed in a private shared storage space which you guys can access. (I made that offer earlier for the other bug, but haven't got a response. I had put the files in my Dropbox account, but they were not taken up.)
Comment 6 narayanaras 2011-07-21 21:25:22 UTC
BTW I used Process Explorer (an erstwhile Systernals product, now taken over by Microsoft). This application is capable of reporting multiple performance parameters like private bytes, page faults, CPU usage, I/O bytes, threads, etc.  It shows performance graphs also.)
Comment 7 narayanaras 2011-07-22 01:18:44 UTC
Created attachment 49417 [details]
Screenshots of Process Explorer (on Windows 7)

The screenshots were taken a few minutes apart. During the entire period, the "Export to PDF" task was at about 25%, and the LibO GUI was visible, but showed an hourglass for mouse pointer. The program did not respond to user-inputs.

The series of screenshots shows that the Private bytes increases linearly till 1.7 GB. That goes on for an hour. All this while the I/O Bytes count is zero. The CPU load is near 49% consistently. 

After an hour, the Private bytes levels off for a couple of minutes. The CPU drops to zero. This state lasts for a couple of minutes.

In the third phase, the Private bytes decreases in sharp steps to zero over the next few minutes. The CPU and I/O bytes remain zero. The program vanishes.
Comment 8 narayanaras 2011-07-22 06:55:51 UTC
I guess there is a breakthrough: I tried to print the file to pdf using a virtual printer, and found that it stops at p.35 (which roughly is same as 20% progress seen in exporting). 

Based on this, I opened the file and went to p.35. Sure enough, I found an image that is displaced from its originally anchored place. Not only that, Libo freezes whenever I try to cross this image, from up-to-down or in reverse.

In general, LibO freezes the moment the picture comes in view anywhere in the screen.

I tried various zoom levels, but the problem is there.

Now that the problem seems to be located, can someone help here?
Comment 9 retired 2013-09-01 11:42:10 UTC
narayanaras: Are you still experience those problems with the latest LO release? http://www.libreoffice.org/download/

If so, could you please attach the document in question (make sure to clean sensitive data) so this can be investigated and fixed?
Comment 10 Jean-Baptiste Faure 2013-11-30 21:58:04 UTC
Three months without answer from reporter: I think we can consider that the problem has been solved in one way or another. 
No problem from my side to export text documents with images to pdf.
So closing as WorksForMe.

Please feel free to reopen if you still experience this problem and can provide concrete elements supporting your bug report.

Best regards. JBF