Bug 39486 - FILEOPEN particular .xls with wrong FORMATTING, row height too small
Summary: FILEOPEN particular .xls with wrong FORMATTING, row height too small
Status: RESOLVED DUPLICATE of bug 34717
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-22 18:43 UTC by mrelwood
Modified: 2017-04-28 20:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
.xls file that the bug appears with. (8.50 KB, application/vnd.ms-excel)
2011-07-22 18:43 UTC, mrelwood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mrelwood 2011-07-22 18:43:38 UTC
Created attachment 49441 [details]
.xls file that the bug appears with.

Creating this bug report as requested at the Nabble:
http://nabble.documentfoundation.org/Incorrect-row-height-when-opening-a-Calc-file-td3189917.html
_

I created an .xls file with OpenOffice 3.3 on OSX 10.6.8. Opening the file now on OSX 10.7, OpenOffice shows the document correctly (row height 0,67cm), but LibreOffice shows the row height at around 0,44cm, which makes about a third of the text to be chopped off. 

The issue appears in about 7% of my .xls files, and on some the text is chopped just slightly. It's easy to re-adjust the row height for a few documents, but I think this is something the devs should take a look at. 

One of the files with the issue as an attachment.
Comment 1 noname 2011-07-23 20:26:25 UTC
Confirmed with [Win2K LibreOffice 3.4.2 OOO340m1 (Build:202)].
Loading the file gives indeed a row height of 0,45 cm instead of 0,67.

But when loading, adjusting and saving with GO-OO 3.2.1, which should be older than your version of OOo (both have the same filesize though), and loading it in LO 3.4.2 it works fine.
Comment 2 Jeffrey 2011-07-24 20:32:27 UTC
Reproduced on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
Comment 3 Björn Michaelsen 2011-12-23 12:25:11 UTC Comment hidden (obsolete)
Comment 4 mrelwood 2011-12-24 13:25:45 UTC
Yes, still happens in LOdev 3.5.0 beta 2 with the attached spreadsheet. Opens
fine in OpenOffice 3.3.0.

This issue originally reported in LibreOffice 3.4.1 release.
Comment 5 Rainer Bielefeld Retired 2012-08-28 04:45:39 UTC
[Reproducible] with "LibreOffice 3.6.1.2  German UI/Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit).

Already a problem with LibO 3.3.0, but ok with AOOo 3.4

I am pretty sure that this one is a DUP of "Bug 34717 - FILEOPEN FORMATTING: automatic row height is too small in particular .xls"

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 34717 ***
Comment 6 Commit Notification 2017-04-28 20:12:52 UTC
Jens Carl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=488d850fd24cd636557bb86b6e4e7cced49a5dd5

tdf#39486: Translate some randomly found German comments

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.