Download it now!
Bug 39496 - Update internal lpsolve to version 5.5.2.0 released Oct 2010 and move it to autotools build system
Summary: Update internal lpsolve to version 5.5.2.0 released Oct 2010 and move it to a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: contrib (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Tomáš Chvátal
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-23 13:53 UTC by Tomáš Chvátal
Modified: 2012-05-14 12:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Patch adding simple autotools to lpsolve 5.5.2.0 release package (5.80 KB, patch)
2011-07-23 13:53 UTC, Tomáš Chvátal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal 2011-07-23 13:53:18 UTC
Created attachment 49448 [details]
Patch adding simple autotools to lpsolve 5.5.2.0 release package

Building lpsolve is seriously annoying thing as it has some bash files called ccc to compile resulting library and binaries

I took the liberty and showed in a simple configure.ac/Makefile.am to provide means to prepare normal tarball with autotools buildsystem that would suffice needs of most distro packagers as well as yours.

For the example tarball see:
http://dev.gentooexperimental.org/~scarabeus/lpsolve-5.5.2.0.tar.xz
RMD160 d19d73238f0aa4f2a219645e4d6478523ab161cf
SHA1 a730f94c1f014e42432ed60de4ab8c678e28a104
SHA256 09d914b43db327fa32c94914917c0db9e4f128c407f41df1dae18df6d2c7573d

The patch I applied against upstream tarball downloadable at http://sourceforge.net/projects/lpsolve/ can be found as an attachment.
Comment 1 Björn Michaelsen 2011-12-23 12:22:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Tomáš Chvátal 2011-12-23 13:19:49 UTC
Bump as per previous comment, this bug is valid.
Comment 3 Michael Meeks 2012-05-08 12:58:56 UTC
Sounds good to me. I guess Kohei would be the guy to review this - Kohei ?

Thomas - do you have a Windows VM to test this stuff inside ? autotools are notoriously unpleasant there; if not - do you have access to the ultra-fast SUSE terminal server for build/test ?
Comment 4 Kohei Yoshida 2012-05-08 13:30:57 UTC
Sorry, what do I need to review?  Isn't this just a packaging issue?
Comment 5 Kohei Yoshida 2012-05-08 13:34:18 UTC
Please go ahead and up the version number.  I don't know enough about lpsolve to say if we should or should not bump up the version number, but normally we don't hold the version number unless there is a very good reason not to (right?).

Since I don't have a reason to say no to upping the version, I'd say go for it.
Comment 6 Kohei Yoshida 2012-05-08 13:34:51 UTC
Re-assigning to Tomas.
Comment 7 Tomáš Chvátal 2012-05-09 08:45:32 UTC
Well even tho I would love to I have no idea how to add this to dmake or how to migrate it to gbuild first.

I think Fridrich or anyone needs to add new version to mirror system and then only the version+mdsum needs to be changed in the .mk file?
Comment 8 Kohei Yoshida 2012-05-09 11:34:21 UTC
(In reply to comment #7)
> Well even tho I would love to I have no idea how to add this to dmake or how to
> migrate it to gbuild first.
> 
> I think Fridrich or anyone needs to add new version to mirror system and then
> only the version+mdsum needs to be changed in the .mk file?

Yes, something like that.  You need to upload the newer version of the package to our package server (I don't think it's mirrored).  Poke Fridrich, Thorsten, Petr or Kendy on how to upload a package to the server.
Comment 9 Tomáš Chvátal 2012-05-14 10:19:18 UTC
Should be resolved by:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21155b8739b1a90455e75b9b527c75e27390455c

So lets see :)
Comment 10 Not Assigned 2012-05-14 10:23:18 UTC
Tomas Chvatal committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21155b8739b1a90455e75b9b527c75e27390455c

Update lpsolve to 5.5.2.0. Resolves bug fdo#39496.
Comment 11 Not Assigned 2012-05-14 12:57:17 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b1692b68f4b314ebc261c40c93c773a905367fb

Revert "Update lpsolve to 5.5.2.0. Resolves bug fdo#39496."