Download it now!
Bug 39511 - VIEWING Print & Web Layout act like toggle switches
Summary: VIEWING Print & Web Layout act like toggle switches
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-24 14:03 UTC by noname
Modified: 2016-10-17 22:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noname 2011-07-24 14:03:00 UTC
1) Select 'view' -> 'Print Layout'
LO switches to Web Layout.

2) Select 'view' -> 'Print Layout' again
LO Switches to Print Layout

Same thing happens when selecting 'view' -> 'Web Layout'

Both functions act like toggle switches, instead just doing their own thing.
So either fix the menuitems or make 1 menuitem that switches both page layouts (like it is now basically).
Comment 1 Rainer Bielefeld Retired 2011-07-25 00:21:59 UTC
Nothing new, I also saw that in OOo 3.1.1
Heritage from OOo, so I modify Version.
Not a real problem, it's a little unexpected, but I doubt that that might cause problems.
But I also agree that the toggle AND selec function seems a little inconsequent.
I did not find a similar pair of icons except from context menu 'Calc -> picture anchor' (to cell <-> to page), that does not toggle.

@Christoph:
Intended?
Comment 2 noname 2011-07-25 10:47:47 UTC
It's not a real problem as in -crash-...
But, having 2 menuitems that do *exactly* the same thing is just bad programming (or bugtesting).
Comment 3 Christoph 2011-07-28 13:51:53 UTC
I second that (re-)selecting each of the items "Print Layout" and "Web Layout" should do what the text implies.

Rationale 1: These items are exclusive and (on Linux) even represented by a group radio buttons. Re-selecting a radio button has to keep the already selected setting.

Rationale 2: If we ever add something like Draft/Outline views, then toggling won't work - then there are more then two states.

@ Rainer:
* I can confirm on "Linux" as well, so Platform = All?
* Removed "infoprovider: Christoph" from whiteboard field

@ xdmx: Excellent feedback - thanks!
Comment 4 Björn Michaelsen 2011-12-23 12:21:06 UTC Comment hidden (obsolete)
Comment 5 Björn Michaelsen 2011-12-23 17:00:54 UTC Comment hidden (no-value)
Comment 6 Florian Reisinger 2012-08-14 13:57:37 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 13:58:57 UTC Comment hidden (obsolete)
Comment 8 Florian Reisinger 2012-08-14 14:03:30 UTC Comment hidden (obsolete)
Comment 9 Florian Reisinger 2012-08-14 14:05:45 UTC Comment hidden (obsolete)