Bug Hunting Session
Bug 39517 - Import of graphic components (charts and tables) from MS Powerpoint broken
Summary: Import of graphic components (charts and tables) from MS Powerpoint broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.2 RC2
Hardware: Other Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-25 01:06 UTC by Branislav Klocok
Modified: 2011-10-29 07:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
original file (152.50 KB, application/vnd.ms-powerpoint)
2011-07-25 01:06 UTC, Branislav Klocok
Details
PDF export with 3.4.2 RC2 (49.10 KB, application/pdf)
2011-07-25 01:08 UTC, Branislav Klocok
Details
PDF export with 3.4.1 (68.42 KB, application/pdf)
2011-07-25 01:26 UTC, Branislav Klocok
Details
What I see after readjusting graph and exporting to PDF (58.88 KB, application/pdf)
2011-07-25 02:17 UTC, Jeffrey
Details
probable fix (972 bytes, patch)
2011-07-25 08:52 UTC, Caolán McNamara
Details
real patch, not pseudo-code this time (972 bytes, patch)
2011-07-25 09:01 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Branislav Klocok 2011-07-25 01:06:49 UTC
Created attachment 49486 [details]
original file

In the 3.4.2 rc2 the import of some components of graphics from MS Power point got broken.
Gustavo_PE.ppt - original file
Gustavo_PE_342RC2.pdf - pdf export from original file in 3.4.2 RC2
Gustavo_PE_341.pdf - pdf export from original file in 3.4.1
Comment 1 Branislav Klocok 2011-07-25 01:08:37 UTC
Created attachment 49487 [details]
PDF export with 3.4.2 RC2
Comment 2 Branislav Klocok 2011-07-25 01:26:09 UTC
Created attachment 49488 [details]
PDF export with 3.4.1
Comment 3 Jeffrey 2011-07-25 02:14:38 UTC
It looks like there is another problems with the attached document. The first chart seems to be sized incorrectly (the line graph). So when you export to PDF directly, it does not show up (because you only have the white portion on the top left of the graph). Re-sizing seems to cause problems as well, but I do not know why. The afterimage of the previous graph remains. Well, after adjusting the size of the image, the pdf export shows the change as well, I presume that the export is ok. The bar graph below shows up when I export fine.

So there is a problem with graphic components. Do you encounter a similar problem with your file?

Also, it looks like you were going to attach a third file but you haven't...
Comment 4 Jeffrey 2011-07-25 02:17:18 UTC
Created attachment 49490 [details]
What I see after readjusting graph and exporting to PDF

Sorry I did not see your third export until after I posted the first comment. It does look like the problem is pretty big because the numbers on the line graph are lost. I am using LibreOffice 3.4  340m1(Build:103)on OpenSuse Linux.
Comment 5 Cor Nouws 2011-07-25 02:42:27 UTC
I confirm the behaviour as described by Branislav on Ubuntu.
Comment 6 Branislav Klocok 2011-07-25 02:49:36 UTC
Jeffrey:
The problems that you have described (resining..) are also occurring. The funny thing is that in 3.4.1 all looks fine.
I have similar problems also with other ppt files. This one was just an example.
Comment 7 Thorsten Behrens (CIB) 2011-07-25 02:58:40 UTC
let me get a build & look into this one.
Comment 8 Petr Mladek 2011-07-25 03:00:51 UTC
Ah, this looks like a serious regression and 3.4.2 release blocker.
Comment 9 Caolán McNamara 2011-07-25 08:52:19 UTC
Created attachment 49532 [details]
probable fix

apparently this is emf+ comment parsing related. Looking through the emf+ records, it looks like the assumption made that the minimum valid record length is 12 + non-0 length payload isnt' right, looks like that the minimum valid record length is just 12, i.e. no need for a payload.
Comment 10 Caolán McNamara 2011-07-25 09:01:43 UTC
Created attachment 49533 [details]
real patch, not pseudo-code this time
Comment 11 Thorsten Behrens (CIB) 2011-07-25 09:16:50 UTC
(In reply to comment #9)
> Created an attachment (id=49532) [details]
> probable fix
> 
> apparently this is emf+ comment parsing related. Looking through the emf+
> records, it looks like the assumption made that the minimum valid record length
> is 12 + non-0 length payload isnt' right, looks like that the minimum valid
> record length is just 12, i.e. no need for a payload.

Yep, to the point. grabbed for master & -3-4, need two more reviews for 3-4-2 now.
Comment 12 Petr Mladek 2011-07-25 09:43:08 UTC
Approved and pushed into 3-4-2 for rc3.