Bug Hunting Session
Bug 39523 - Merge menu items in Impress
Summary: Merge menu items in Impress
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Toolbars
  Show dependency treegraph
 
Reported: 2011-07-25 06:23 UTC by Leif Lodahl
Modified: 2018-11-20 11:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Lodahl 2011-07-25 06:23:31 UTC
The menu items "Insert - Page number..." (InsertPageNumber) and "Insert - Date and Time..." (InsertDateAndTime) is both pointing to the same dialog: "Header and Footer".

These two menu items should be merged into one: "Insert - Footer elements".
Comment 1 Björn Michaelsen 2011-12-23 12:27:51 UTC Comment hidden (obsolete)
Comment 2 Leif Lodahl 2011-12-27 14:06:43 UTC
Still relevant.
Not actually a bug but more an easy improvement to the user interface. One dialog with three different things to insert has two entries in the "insert" menu.
Comment 3 Florian Reisinger 2012-08-14 14:03:22 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:04:17 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:08:49 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:10:50 UTC Comment hidden (obsolete)
Comment 7 Björn Michaelsen 2012-08-15 20:13:52 UTC
I wonder why this wasnt set back to NEW along with the reasoning in Comment 2 as was suggested in Comment 1. Anyway reopening.

CCing Astron, just to quickly check back, if there are any hidden concerns from the UX perspective. Otherwise I would think this would even qualify as a wonderful EasyHack.
Comment 8 Stefan Knorr (astron) 2012-08-15 21:27:17 UTC
Hi there.
I almost think that's fine as it is today, as users will not be searching for (random) "footer elements" – they will be searching for how to insert slide numbers and the time and date.
Unless we can word that significantly better than "footer elements," I'd vote to keep the current version. Even if it's odd that both entries open the same dialogue on the same page.
Comment 9 Michael Meeks 2012-08-16 16:38:47 UTC
So - perhaps in other languages there is some intuitive word that people will immediately see and act on that works better than English.

If so - I guess we could try to identify such languages and adapt the UI in some way - but that's real work.

Leif - I tend to agree with Astron; what's your take ?
Comment 10 Leif Lodahl 2012-08-16 19:36:59 UTC
Disagree.
We should try to make the user interface more simple - not more complicated. I don't know of other situations where we have dual menu items to the same function. 

But we should of cause find other expressions. I originally suggested "Insert - Footer elements" but I'm open to suggestions here ;-)

Should we call for the cavalry (Design/UX-guys)?


Cheers,
Leif
Comment 11 sasha.libreoffice 2012-09-29 07:13:01 UTC
What is interesting: in msPP 2003 done exactly the same: two menu items point to the same dialog. Therefore this done for compatibility with PP.
Comment 12 QA Administrators 2013-05-29 23:04:55 UTC Comment hidden (obsolete)
Comment 13 Florian Reisinger 2013-05-30 06:15:31 UTC
Should be NEW #7
Comment 14 Leif Lodahl 2013-05-30 07:51:41 UTC
(In reply to comment #11)
> What is interesting: in msPP 2003 done exactly the same: two menu items
> point to the same dialog. Therefore this done for compatibility with PP.
That is not a valid reason. We should not replikate all MS mistakes for /compatibility reasons/.

I rest my case and give up.
But I still think that we should make our GUI as simple as possible and not more complex than necessary.

Cheers,
Leif
Comment 15 Stefan Knorr (astron) 2013-06-04 16:57:13 UTC
Leif, the problem is your suggested wording. "Footer elements" sounds like all or nothing. "Date and Time" and "Page Number" mean something to users.

I admit, I didn't think too hard about this, but I couldn't come up with a better solution.

And you should have seen my mother's look when I told her that adding a page number to a Writer document entails going to a sub-menu called Fields (although, in my native German, it is actually worse; it's Feldbefehle, i.e. Field Commands there).
Comment 16 Roman Kuznetsov 2018-11-20 11:50:08 UTC
in 

Версия: 6.2.0.0.beta1
ID сборки: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded

I see item Insert->Header and Footer

Item Insert->Field->Slide number inserts slide number to current slide. The same works for Insert->Field->Date and inserts current date to current slide.

Status->WFM