Download it now!
Bug 39555 - 256px Desktop icons are missing
Summary: 256px Desktop icons are missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-26 05:55 UTC by pe721
Modified: 2012-03-20 03:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots, see Comment 3 (129.69 KB, application/pdf)
2011-07-26 22:49 UTC, Rainer Bielefeld Retired
Details
Example text-template icon (282.47 KB, image/x-icon)
2012-01-20 07:52 UTC, ape
Details
new images example (36.80 KB, image/png)
2012-01-25 08:38 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pe721 2011-07-26 05:55:24 UTC
On windows, icons included are 128px only.
They should be at 256px
Comment 1 Rainer Bielefeld Retired 2011-07-26 10:37:09 UTC
@pe721:
How can that be reproduced?
Comment 2 pe721 2011-07-26 12:01:34 UTC
you can either look at your desktop and see that, in the "Large Icons" view, the icons are not "large" (256px) or open the "soffice.exe" file in a resource viewer program (like Anolis.Resourcer here: http://anolis.codeplex.com/) and see that the 256px icons are missing.

i hope this is clearer. Sorry if i do something wrong, i'm new here...


(In reply to comment #1)
> @pe721:
> How can that be reproduced?
Comment 3 Rainer Bielefeld Retired 2011-07-26 22:35:41 UTC
[Reproducible] with "LibreOffice 3.4.1 RC3 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]". Desktop icons and
Also see that with very old LibO 3.3.0 Portable, so I believe that's from the beginning. It seems not all Programs have those "big" Icons, see screenshots, but OOo has.
Saw that with Icons on Desktop and WIN explorer, others not tested.

@pe721@hotmail.com:
Thank you for your attention!

@tester8:
Can you please check for Linux?
Comment 4 Rainer Bielefeld Retired 2011-07-26 22:49:32 UTC
Created attachment 49597 [details]
Screenshots, see Comment 3

For got to mention: might have been intended to leave those big icons away?
Comment 5 tester8 2011-07-30 05:10:40 UTC
Reproduced with

LO 3.4.2 OOO340m1 (Build:202)
Ubuntu 10.04.3 x86
Linux 2.6.32-33-generic Russian UI

Because Linux supports svg icons and LO icons was originnaly vector it would be nice to also have .svg variant, not just 256x256.
Comment 6 Rainer Bielefeld Retired 2011-07-30 07:48:40 UTC
(In reply to comment #5)

I filed "Bug 39690 - Contribute Desktop icons as .svg" for that suggestion.
Comment 7 Petr Mladek 2011-10-21 07:55:51 UTC
Thorsten, Christoph, could we push them under sysui/desktop/icons/hicolor/256x256?

It would help me to solve https://bugzilla.novell.com/show_bug.cgi?id=722644 ;-)
Comment 8 Björn Michaelsen 2011-12-23 13:23:53 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 10 Andras Timar 2012-01-12 03:42:53 UTC
(In reply to comment #9)
> 
> => FIXED

It does not solve the problem of Windows icons which are in .ico files. But I have it on my TODO list and will do for 3.5.
Comment 12 ape 2012-01-20 07:48:40 UTC
LibreOffice-3.5.0rc1_win_x86
Composition of the icons, placement and size of the first page image wrong. WindowsXP/Server2003 Explorer icon in the uncompressed 256x256 pixels can not show. The images in 128x128 pixels operating system is not used. The correct icon (Windows XP, Vista, Seven) contains the following sequence of images: the first picture - uncompressed, has a size of 256x256, the second - 48x48, third - 32x32, the fourth - 16x16 and fifth - 96x96 pixels.
Comment 13 ape 2012-01-20 07:52:45 UTC
Created attachment 55835 [details]
Example text-template icon
Comment 14 ape 2012-01-21 03:13:36 UTC
Hi Andras,
I read the message (http://nabble.documentfoundation.org/REVIEW-3-5-remove-duplicated-icons-from-soffice-bin-soffice-exe-fdo-37740-tp3670472p3670472.html) and understood the problem this way:
1. Necessary to minimize the file size in order to ensure the shortest time the application starts.
2. It is necessary that Explorer operating system "Windows XP-Seven" show labels the correct size.
I propose this solution:
1. The files (soffice.exe, sbase.exe, scalc.exe, sdraw.exe, simpress.exe, smath.exe, sweb.exe, swriter.exe and quickstart.exe) contain a one icon. Icon consists of four PNG-images. The first image compressed, has a size of 256 by 256 pixels. The second image is 32 by 32 pixels. The third image is 16 by 16 pixels. The fourth image is of size 48 by 48 pixels. In this case, the file size is about 41 KB, now - 1.78 MB.
2. You must create an additional library of icons - the "soffice.dll" file. All necessary Explorer icon located in the library. Each icon contains 5 uncompressed images of the same color depth. The first image has a size of 256 by 256 pixels. The second image has a size of 48 by 48 pixels. The third image is 32 by 32 pixels. The fourth image is 16 by 16 pixels. The fifth image has a size of 96 by 96 pixels. You must change the registration files the operating system. Here is an example for file "*. doc".
Current value:
[HKEY_CLASSES_ROOT\OpenOffice.org.Doc\DefaultIcon]
@="C:\\Program Files (x86)\\LibreOffice\\program\\soffice.exe,27"
Correction:
[HKEY_CLASSES_ROOT\OpenOffice.org.Doc\DefaultIcon]
@="C:\\Program Files (x86)\\LibreOffice\\program\\soffice.dll,27"
3. I expressed my solution file "soffice.bin" in error messages (bug_id-37740).
The proposed solution (pp.1-3) does not affect the code "LibreOffice-3.3;-3.4;-3.5" and I used ("Easy Hack") more than one year (Windows NT-5.2).
Serg.
P.S. Sorry, I was not able to answer "Nabble".
Comment 15 Andras Timar 2012-01-24 07:48:08 UTC
(In reply to comment #14)
> Hi Andras,
> I read the message
> (http://nabble.documentfoundation.org/REVIEW-3-5-remove-duplicated-icons-from-soffice-bin-soffice-exe-fdo-37740-tp3670472p3670472.html)

Hi, 

soffice.bin must contain all application icons. swriter.exe, scalc.exe etc. are only launchers, their icons are not used in the running application.

So, in my solution there is 1 icon in soffice.exe and only 14 icons in soffice.bin instead of 40.
Comment 16 Andras Timar 2012-01-24 07:52:35 UTC
(In reply to comment #12)
> LibreOffice-3.5.0rc1_win_x86
> Composition of the icons, placement and size of the first page image wrong.
> WindowsXP/Server2003 Explorer icon in the uncompressed 256x256 pixels can not
> show. The images in 128x128 pixels operating system is not used. The correct
> icon (Windows XP, Vista, Seven) contains the following sequence of images: the
> first picture - uncompressed, has a size of 256x256, the second - 48x48, third
> - 32x32, the fourth - 16x16 and fifth - 96x96 pixels.

I don't really mind, if 256x256 icons are not shown under Windows XP. These large icons are for Vista and above. When I chose Large Icons under Windows 7, 128x128 icons were displayed. When I chose Extra Large Icons, 256x256 icons were displayed. Did you see something different?
Comment 17 ape 2012-01-25 08:38:26 UTC
Created attachment 56149 [details]
new images example

You are right: Explorer_NT-5.1,2 shows a large image (96x96px) only icon files and no-shows at the label (see illustration). Image 96 for 96 pixels in the icon unnecessary. In this case, the sequence of images: a concise_256x256px, 32x32px, 16x16px and 48x48px - will be optimal. My version of Office uses 40 different images contained in a separate library (added 3 more types of graphics primitives, see illustration). I can place materials on this preliminary work, if they interest you. I apologize for the slowness - this is my problem with the English language.
Comment 18 Andras Timar 2012-03-20 03:48:07 UTC
I'm a bit confused about the status of this bug. I think the original problem has been solved. We have 256px icons both in Windows and Linux. For further improvements or patches please use a new bug or the dev mailing list.