Bug 39690 - Contribute Desktop icons as .svg
Summary: Contribute Desktop icons as .svg
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-30 07:48 UTC by Rainer Bielefeld Retired
Modified: 2012-04-12 04:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the strange broder around macro icon (74.48 KB, image/png)
2012-02-03 05:47 UTC, Petr Mladek
Details
Icons (1.96 MB, application/zip)
2012-02-10 10:41 UTC, tester8
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-07-30 07:48:05 UTC
Spin off from "Bug 39555 - 256px Desktop icons are missing", suggestion of tester8

Might be a good idea to have Desktop icons as .svg and supply bitmaps for OS that do not support vector graphics for icons.
Comment 1 Petr Mladek 2011-10-21 07:51:59 UTC
Thorsten, Christoph, are they available anywhere?

They can be installed on system to the icons/hicolor/scalable subdirectory. So, we need them in the sources under sysui/desktop/icons/hicolor/scalable.

Note that we are looking also for the 256x256 size, see the bug #39555.
Comment 2 Björn Michaelsen 2011-12-23 12:24:06 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 tester8 2011-12-29 15:35:02 UTC
LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

Still reproduced.
Comment 4 Thorsten Behrens (CIB) 2012-01-10 02:54:09 UTC
Present mimetype icons seem to be here: http://wiki.documentfoundation.org/images/3/3e/LibreOffice_Initial_Icons_Bernhard_draft_0-1.svg (link might change, [Media:LibreOffice_Initial_Icons_Bernhard_draft_0-1.svg] in the wiki should remain working).
Comment 5 Petr Mladek 2012-01-10 09:57:03 UTC
The svg seems to be incomplete. I think that the final svg is at
http://wiki.documentfoundation.org/File:LibreOffice_Initial_Icons-pre_final.svg

I am going to add the icons.
Comment 6 Petr Mladek 2012-01-11 05:43:00 UTC
Hmm, I have updated http://wiki.documentfoundation.org/File:LibreOffice_Initial_Icons-pre_final.svg and provided 256 icons to fix the bug #39555.

I can't find a reasonable way how to generate the scalable .svg files for each icon from the huge .svg. It works neither from inkscape commandline, nor from UI. Anyone has any idea?
Comment 7 tester8 2012-01-11 12:06:41 UTC
>Anyone has any idea?
I can ask on linuxgraphics.ru forum when my account will confirmed.
Comment 8 tester8 2012-01-12 06:02:37 UTC
Petr Mladek,
How do you generate .pngs, can you publish script or something?
May be it helps with svg.
Comment 9 Petr Mladek 2012-01-13 05:15:54 UTC
The .pngs are generated using the script http://users.freedesktop.org/%7Ethorsten/bin/cnvsvg.py. So, it cals:

inkscape -i <some_object_id> -e out_file.png LibreOffice_Initial_Icons-pre_final.svg

I tried to use -l/--export-plain-svg instead of the -e option but it did not work. It produced .svg file with all objects and complained that the PNG file name was not defined and it was not able to generate it.

I tried to search something usable in the inkscape menu but without success.

One solution would be to cut and paste the selected parts into extra .svg files but it is a bit painful. Also I am not sure if it keeps the correct vector definition.
Comment 10 tester8 2012-01-13 14:47:09 UTC
>I tried to search something usable in the inkscape menu but without success.
I haven't any good news too. Forum admin wrote to me: "Sometimes this questions asked but there is no any solution yet."
So I think we should ask Inkscape developers and if there is no way other than manually it will be feature request.

BTW there is a new nice tool to clean svg
http://libregraphicsworld.org/blog/entry/introducing-svg-cleaner
It reduces size of LibreOffice_Initial_Icons-pre_final.svg twice.
Comment 11 tester8 2012-01-13 16:38:54 UTC
I found a volunteer to do it manually )
But he needs list with filenames for export, or better this plus all png pictures properly named. Where can I get it (can't copy from my installation because of lodev in names)?

I should ask him to accept Creative Commons Attribution-ShareAlike 3.0 Unported License, do I?

>Also I am not sure if it keeps the correct vector definition.
Please explain in detail.

But this does not cancell my words about feature request.
Comment 12 tester8 2012-01-15 07:24:51 UTC
It was not easy but one sophisticated way was founded and now it is done.

Here is discussion in Russian: http://linuxgraphics.ru/forum/viewthread.php?thread_id=1149&pid=11782#post_11754.

There is my free translation of main amuriy's comment with some additions:
_____________________________________________________
To make works export to separate files by ID it is needed: first delete "transform" attribute from "top" layer properties (it is advaced here: https://bugs.launchpad.net/inkscape/+bug/743987). What have I done: group all objects for each icon and move them to the new layer without "transform" attribute. Delete empty layers (automatically it can be done with SVG Cleaner).

Then run shell-script http://pastebin.com/HbHFbaNy --> export off all the groups from *.svg to PDF --> then with pdf2svg http://www.cityinthesky.co.uk/opensource/pdf2svg back to SVG. 

Bad thing that it exports ALL thr groups and some of theem is empty for some unknown reason so result SVG'S should be sorted manually...

There is resulted svgs:
http://rghost.ru/35903405
_____________________________________________________

Then we found mistake in g103115.svg (some bug in svg->pdf). Corrected image is there: http://linuxgraphics.ru/forum/viewthread.php?thread_id=1149&getfile=11782
But may be there is an errors in some other images I have check only some first.
Comment 13 Petr Mladek 2012-02-03 05:47:52 UTC
Created attachment 56573 [details]
Screenshot of the strange broder around macro icon

First, I am sorry for the late replay. There were more urgent things that needed to be done before 3.5.0 release.

Second, I was not able to download the svg icons from http://rghost.net/35903405. The file was marked as deleted. Also it asked for my credit-card number that I did not want to give.

Third, the picture from http://linuxgraphics.ru/forum/viewthread.php?thread_id=1149&getfile=11782 looks promising. The only problem is the strange border around the icon. I do not see it in the original svg with all the icons.

IMHO, the tarball with all icons should not be that huge. We need the following icons:

    scalable/apps/calc.svg
    scalable/apps/base.svg
    scalable/apps/main.svg
    scalable/apps/math.svg
    scalable/apps/writer.svg
    scalable/apps/startcenter.svg
    scalable/apps/draw.svg
    scalable/apps/impress.svg
    scalable/mimetypes/oasis-drawing.svg
    scalable/mimetypes/oasis-web-template.svg
    scalable/mimetypes/oasis-drawing-template.svg
    scalable/mimetypes/oasis-master-document.svg
    scalable/mimetypes/oasis-database.svg
    scalable/mimetypes/oasis-text.svg
    scalable/mimetypes/oasis-spreadsheet.svg
    scalable/mimetypes/oasis-presentation.svg
    scalable/mimetypes/oasis-spreadsheet-template.svg
    scalable/mimetypes/oasis-text-template.svg
    scalable/mimetypes/oasis-formula.svg
    scalable/mimetypes/oasis-presentation-template.svg


Please, look at https://gitorious.org/libreoffice/core/trees/master/sysui/desktop/icons/hicolor to see how the corresponding .png icons look like.
Note that the "startcenter" and "main" icons are the same.

Also note that the primary source should be accessible via http://cgit.freedesktop.org/libreoffice. Unfortunately, this service does not work today, so I send link to the read-only copy on gitorious.org.


Conclusion:

Could you please remove the strange border?
Could you please attach only the wanted svg icons to this bug?

It would help a lot.
Comment 14 tester8 2012-02-10 10:40:45 UTC
>Could you please remove the strange border?
It is Inkscape page border. I have turn it off (File->Document properties->Show page border), anyway it should not be displayed in any app excluding Inkscape.

>Could you please attach only the wanted svg icons to this bug?
Yes, but there is a problem: summary size of result is 14 MB (original file is 1.8 MB). I tried to reduce it with svg cleaner, but it damage files.
Comment 15 tester8 2012-02-10 10:41:54 UTC
Created attachment 56884 [details]
Icons
Comment 16 Not Assigned 2012-04-12 04:34:23 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=250feedd8e50e5eb52682a194823567ba5287c60

add scalable desktop icons (fdo#39690)
Comment 17 Petr Mladek 2012-04-12 04:41:40 UTC
@tester8: thanks a lot for the updated icons. I have finally got time to look at it again and pushed them into master.

I did few more changes:

    * replaced impress.svg with oasis-presentation.svg because there was missing
      the green "line" in the chart
    * fixed draw.svg and *drawing*.svg; there was a box around the circle
    * added an invisible box around all icons to get the printable area
      256x256 square instead of the rectangle (like we have for png icons)