Bug Hunting Session
Bug 39655 - When the spreadsheed is saved as .xls (office 97) the second sheet (on footerpage) starts whith 0 (zero)
Summary: When the spreadsheed is saved as .xls (office 97) the second sheet (on footer...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: XLS
  Show dependency treegraph
 
Reported: 2011-07-28 20:24 UTC by Roberto
Modified: 2017-07-20 00:26 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot on Excel, LibO and AOO (187.78 KB, image/png)
2015-02-02 17:15 UTC, ifanlo
Details
sample document (14.50 KB, application/vnd.ms-excel)
2015-02-02 17:17 UTC, ifanlo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto 2011-07-28 20:24:13 UTC
Bug on footerpage of 2nd sheet (CALC)
How to reproduce the problem:

Tested on Windows 7 64b and Windows XP 32b.
Tested on LibreOffice Versions: (Portuguese Brazilian)
3.3.3
3.4.1

1) With CALC, build a New SpreadSheet, on the sheet 1 and 2, let the footerpage as # of ## (page number of pages)
2) Save as .xls (office 97 format)
3) Close

4) Reopen and go to 2nd sheet, see the preview... footer must to show p.e. page 1 of 1, but shows page 0 of 1 !? On the 1st sheet the preview is OK, the problem appears on the next sheets ...

Roberto Novakosky
Comment 1 Jeffrey 2011-07-29 02:54:07 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

Followed the steps, viewed the sheets on File->Page preview, problem exactly as reporter mentioned.
Comment 2 Roberto 2011-07-29 05:41:37 UTC
New Test

With the file .xls created on CALC:

indicates that the file is correct your data structure, so the problem probably resides on functions from CALC that load the .xls to memory.
Comment 3 Roberto 2011-07-29 05:44:12 UTC
New Test

With the file .xls created on CALC:

If it is opened on MS Office, it works fine, so it indicates that the file is correct your data structure, so the problem probably
resides on functions from CALC that load the .xls to memory.
Comment 4 Björn Michaelsen 2011-12-23 12:27:52 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:03:25 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:04:20 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:08:52 UTC Comment hidden (obsolete)
Comment 8 Florian Reisinger 2012-08-14 14:10:53 UTC Comment hidden (obsolete)
Comment 9 Roberto 2012-09-05 11:53:14 UTC
New tests on Version 3.6.1.2 of LibreOffice CALC.
BUG reconfirmed.
Comment 10 pierre-yves samyn 2012-09-15 12:56:03 UTC
Hello

I reproduce with Version 3.6.2.1 (Build ID: ba822cc) & Windows 7 64bits

Regards
Pierre-Yves
Comment 11 Leopoldo Saggin 2012-10-17 09:32:42 UTC
I can confirm this bug on 2nd tab [shhet] of a .xls spreadsheet (saved as Excel 1997-2003) ONLY in preview mode (the print in fact starts correct from number 1) in a Windows 7 Pro 64 bits environment and LibreOffice 3.6.2.2 version for Windows.

Beste regards,
Leopoldo Saggin aka Topoldo
Comment 12 Joel Madero 2014-11-06 21:09:13 UTC
Version is oldest version not newest. Reverting change.

Also requesting confirmation from QA team as that hasn't been done - moving to UNCONFIRMED.
Comment 13 Roberto 2014-11-07 11:35:12 UTC
Tested again on Version 4.2.6.3. (on WIN XP 32)
Reconfirmed the problem.
Comment 14 Joel Madero 2014-11-07 16:08:22 UTC
Please don't confirm your own bugs .. also don't update the version as version is the oldest version, not newest.
Comment 15 Buovjaga 2014-11-16 19:13:10 UTC
By footerpage, I assume you mean the Page indicator in the Status bar.
For me, it shows Page 1 / 0 in the preview even when I've just created the sheets, so no change when saving to .xls.

I'd like to see screenshots "ok" and "not ok".

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 16 ifanlo 2015-01-24 08:40:22 UTC
Confirmed in 4.3.5.2 Windows and 4.2.7.2 Linux Ubuntu.
ONLY in preview, not on printing.

Note: AOO 4.1.1 not has this problem.
Comment 17 Buovjaga 2015-01-24 15:34:48 UTC
(In reply to ifanlo from comment #16)
> Confirmed in 4.3.5.2 Windows and 4.2.7.2 Linux Ubuntu.
> ONLY in preview, not on printing.
> 
> Note: AOO 4.1.1 not has this problem.

Can you give screenshots of both LibreOffice & AOO?
Comment 18 ifanlo 2015-02-02 17:15:39 UTC
Created attachment 113057 [details]
screenshot on Excel, LibO and AOO
Comment 19 ifanlo 2015-02-02 17:17:20 UTC
Created attachment 113058 [details]
sample document
Comment 20 ifanlo 2015-02-02 17:18:45 UTC
(In reply to Beluga from comment #17)
> 
> Can you give screenshots of both LibreOffice & AOO?

Attached!
Comment 21 Buovjaga 2015-02-02 18:03:06 UTC
(In reply to ifanlo from comment #18)
> Created attachment 113057 [details]
> screenshot on Excel, LibO and AOO

Thanks.

I get the same in LibreOffice as your Excel screenie, 1/1 so no problem for me.

Can you test with 4.4?

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7

Version: 4.5.0.0.alpha0+
Build ID: 4b9a9ce8a0e5e0716dad9a9ec87d16237e534dc2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-31_09:49:44

Ubuntu 14.10 64-bit
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Comment 22 QA Administrators 2015-09-04 02:55:40 UTC Comment hidden (obsolete)
Comment 23 Buovjaga 2015-09-08 17:50:29 UTC
Roberto: do you confirm this problem with LibO 5.0.x?
Comment 24 Roberto 2015-09-08 17:59:03 UTC
Problem confirmed on 5.0.x (Tested on 5.0.1.2)

Roberto
Comment 25 raal 2015-09-27 08:40:42 UTC
I can confirm with Version: 5.1.0.0.alpha1+
Build ID: 83ef294dddf3b1ab5cd5f91a792a7d9413a08f1f
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-20_07:00:46
Sheet Hoja1 is correct, sheet Hoja2 is incorrect (0/1) . Works OK in excel2010.
Comment 26 QA Administrators 2016-11-08 10:33:11 UTC Comment hidden (obsolete)
Comment 27 Roberto 2016-11-17 11:39:19 UTC
Confirmed Problem
Version Tested: 
LibreOffice 5.2.3.3 (latest version at the moment)
SO: Windows 7 Pro 64b
Comment 28 Timur 2017-07-18 09:47:42 UTC
Roberto, thank you for following your bug but version 5.2.3 is not latest.
Not reproducible with: master, 5.3.4, 5.2.7. So I'll close as WFM since fix is not known. There was somewhat related Bug 77111, if you tested you old files. 

You may get http://tdf.io/siguiexe to easily get and run "parallel" LO in Windows (extract without installation) in order to test newest and still not for production LO versions, like 5.4 and master 6.0+.
If you confirm the bug with master or 5.3.4, please note.
Comment 29 Timur 2017-07-18 09:49:50 UTC
Thomas, I don't see the point of all those broad Meta bugs, such as XLS, but if you add it, please test before.
Comment 30 Roberto 2017-07-20 00:26:45 UTC
Resolved Task
Test OK ON LibreOffice Version: 5.2.7.2