Download it now!
Bug 39722 - DOCX with SmartArt Fails To Open content
Summary: DOCX with SmartArt Fails To Open content
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-01 09:01 UTC by Dave Richards
Modified: 2019-10-01 08:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document that fails import filter. (738.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-08-01 09:01 UTC, Dave Richards
Details
Document compared MSO LO (724.15 KB, image/png)
2019-10-01 08:35 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2011-08-01 09:01:33 UTC
Created attachment 49792 [details]
Document that fails import filter.

Libre blinks once when opening this document and the content never appears.  Same results in OpenOffice.  

We had to open with MS Office and downgrade to .odt and forward to resolve this issue.
Comment 1 tester8 2011-08-01 13:58:58 UTC
Not reproduced with:

LO 3.4.2 OOO340m1 (Build:202)
Ubuntu 10.04.3 x86
Linux 2.6.32-33-generic Russian UI

I can open document, but it is empty. Should it be empty?
What is your OS version?
Comment 2 Dave Richards 2011-08-02 05:38:47 UTC
I am running on 64bit Linux.  Yes, the document contains photos and text when opened from Microsoft Office.
Comment 3 Korrawit Pruegsanusak 2011-08-16 04:27:18 UTC
Seems your docx has "SmartArt", and Writer doesn't open it.
Confirmed with LibO 3.4.2 final WinXP

And, I found Bug 37932 - Smart art support ...
Thorsten, could you please
Comment 4 Korrawit Pruegsanusak 2011-08-16 04:29:16 UTC
Oops, it should read:
"Thorsten, could you please elaborate on your SmartArt support you're working?"
Comment 5 Thorsten Behrens (CIB) 2011-08-16 05:46:45 UTC
(In reply to comment #4)
> "Thorsten, could you please elaborate on your SmartArt support you're working?"
>
Yeah, initial bits are in master currently - though nothing yet for Writer.
Comment 6 Korrawit Pruegsanusak 2011-10-07 23:44:37 UTC
(In reply to comment #5)
> Yeah, initial bits are in master currently - though nothing yet for Writer.

So, SmartArt is currently like a not-supported-yet => Mark as duplicate for "Smart art support" bug. Thanks anyway!

*** This bug has been marked as a duplicate of bug 37932 ***
Comment 7 Timur 2019-10-01 08:35:29 UTC
This is not a duplicate. It didn't work and started working, somehow in 4.1 and fine in 5.3. Also OK now in 6.4+. So it's WFM.
Comment 8 Timur 2019-10-01 08:35:54 UTC
Created attachment 154665 [details]
Document compared MSO LO