Bug Hunting Session
Bug 39724 - LibreOffice is not able to load flat xml .ods document any more
Summary: LibreOffice is not able to load flat xml .ods document any more
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-08-01 10:54 UTC by Kristof Ralovich
Modified: 2012-03-07 01:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
flat xml i/o filters (4.50 KB, application/octet-stream)
2011-08-01 10:54 UTC, Kristof Ralovich
Details
test-case flat xml .ods that is not loading with libreoffice 3.4.2 (19.00 KB, application/vnd.oasis.opendocument.spreadsheet-flat-xml)
2011-08-01 11:02 UTC, Kristof Ralovich
Details
fods file is not properly recognised (6.40 KB, image/png)
2011-12-25 06:15 UTC, Kristof Ralovich
Details
test-case opened as plain xml (55.91 KB, image/png)
2011-12-25 06:16 UTC, Kristof Ralovich
Details
test-case opens properly after flat xml i/o filters were installed (44.68 KB, image/png)
2011-12-25 06:17 UTC, Kristof Ralovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kristof Ralovich 2011-08-01 10:54:26 UTC
Created attachment 49793 [details]
flat xml i/o filters

LibreOffice is not able to load flat xml .ods document any more. 3.4.1 and before worked just fine, but 3.4.2 is not able load it anymore.
Comment 1 Kristof Ralovich 2011-08-01 10:55:23 UTC
As a workaround I can use flat.jar (see attachment) xml i/o filters.
Comment 2 Kristof Ralovich 2011-08-01 11:02:33 UTC
Created attachment 49794 [details]
test-case flat xml .ods that is not loading with libreoffice 3.4.2

test-case flat xml .ods that is not loading with libreoffice 3.4.2
Comment 3 tester8 2011-08-01 13:54:32 UTC
NOT reproduced with:

LO 3.4.2 OOO340m1 (Build:202)
Ubuntu 10.04.3 x86
Linux 2.6.32-33-generic Russian UI

Kristof Ralovich , what is exactly your OS version?
Comment 4 Kristof Ralovich 2011-08-01 14:00:04 UTC
(In reply to comment #3)
> NOT reproduced with:
> 
> LO 3.4.2 OOO340m1 (Build:202)
> Ubuntu 10.04.3 x86
> Linux 2.6.32-33-generic Russian UI
> 
> Kristof Ralovich , what is exactly your OS version?

LibreOffice 3.4.2 
OOO340m1 (Build:203)
Windows7 SP1 64-bit
Comment 5 noname 2011-08-01 14:38:32 UTC
Not confirmed with [Win2K LibreOffice 3.4.2 OOO340m1 (Build:203)].
File loads as expected without your flat filter.

Have you tried repairing LO with the setup script ? This sometimes helps, as it copies new versions over damaged ones.
Comment 6 Björn Michaelsen 2011-12-23 12:25:39 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Kristof Ralovich 2011-12-25 06:08:02 UTC
I've just tried, and is still present with on win32 xp:

LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Comment 8 Kristof Ralovich 2011-12-25 06:09:30 UTC
(In reply to comment #7)
> I've just tried, and is still present with on win32 xp:
> 
> LOdev 3.5.0beta2 
> Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978

Forgot to mention, LOdev was freshly installed after un-installing all previous version of LO.
Comment 9 Kristof Ralovich 2011-12-25 06:15:44 UTC
Created attachment 54808 [details]
fods file is not properly recognised
Comment 10 Kristof Ralovich 2011-12-25 06:16:56 UTC
Created attachment 54809 [details]
test-case opened as plain xml
Comment 11 Kristof Ralovich 2011-12-25 06:17:50 UTC
Created attachment 54810 [details]
test-case opens properly after flat xml i/o filters were installed
Comment 12 Dag Wieers 2012-02-02 01:22:47 UTC
For people having this same issue, you can enable Flat ODF in your LibreOffice
installation by rerunning setup and modifying the installation to include:

    Sample XSLT Filters

So:

    setup.exe -> Modify -> Optional Components -> XSLT Sample Filters

Should get you the required filters for using Flat ODF files on Windows.

The above configuration should no doubt become the default on Windows !
Comment 13 Michael Stahl (CIB) 2012-02-07 05:06:28 UTC
looks like a windows-only installation regression?
Comment 14 Andras Timar 2012-02-07 06:16:50 UTC
> 
> The above configuration should no doubt become the default on Windows !

Fridrich enabled it, unfortunately too late for 3.5.0. Will be in 3.5.1.
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=0b2ab2969d50559b68055e564ca739abad5b6c8c
Comment 15 Dag Wieers 2012-02-07 07:04:21 UTC
Great to hear. Could it be updated for 3.4.6 too ?
Comment 16 Andras Timar 2012-02-07 07:42:13 UTC
(In reply to comment #15)
> Great to hear. Could it be updated for 3.4.6 too ?

Why not... Pushed to libreoffice-3-4 branch, too.
Comment 17 Dag Wieers 2012-02-07 07:45:35 UTC
Thanks ! I updated it in our tracker too, so new users can find the relevant information.

https://github.com/dagwieers/asciidoc-odf/issues/22
Comment 18 pirri 2012-02-13 08:27:04 UTC
And for people like me, who is in the middle of a project of deploying LibO 3.4.5 in a corporation (4K machines), and we want to change from RTF to FOdt, is there a solution/workarround?

3.4.6 and 3.5.1 are too far for us, we must deploy LibO 3.4.5 next monday. 

We can modify the MSI installer with ORCA (in fact we did it to disable auto updates, remove some languages, etc), but we have no idea about what exactly do we have to change to deploy LibO 3.4.5 with the XSLT Samples component by default.

Any help will be welcomed.
Comment 19 Andras Timar 2012-02-13 14:00:51 UTC
(In reply to comment #18)
> And for people like me, who is in the middle of a project of deploying LibO 3.4.5 in a corporation (4K machines), and we want to change from RTF to FOdt, is
> there a solution/workarround?
> 
> 3.4.6 and 3.5.1 are too far for us, we must deploy LibO 3.4.5 next monday. 
> 
> We can modify the MSI installer with ORCA (in fact we did it to disable auto updates, remove some languages, etc), but we have no idea about what exactly do we
> have to change to deploy LibO 3.4.5 with the XSLT Samples component by default.
> 
> Any help will be welcomed.

In Orca open the Feature table, find gm_o_Xsltfiltersamples, and set the Level to 20 (it is 200 by default).