Bug Hunting Session
Bug 39731 - spell checker does not spell check
Summary: spell checker does not spell check
Status: CLOSED DUPLICATE of bug 37195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-01 15:17 UTC by reussandras
Modified: 2012-01-21 21:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description reussandras 2011-08-01 15:17:37 UTC
the spell checker does nothing, it does not underline anything
Comment 1 vitriol 2011-08-01 23:20:50 UTC
AutoSpellcheck is active? -> If yes, have you updated your LibO 3.4.2 from a previous version? -> If yes, see Bug 37195 and let us know if is your case.
Comment 2 reussandras 2011-08-02 01:03:02 UTC
I identified finally the cause of the problem: it seems that the software did not installed the language packs, thought I ordered to. I reinstalled the 3.4.1 version, it did not worked either, same problem. In the language settings, there was not a green tick for neither language, thought I did install french, hungarian and english languages. Curious. 
Then I found a workaround: I zipped dict-hu in the share/extensions directory and installed with the extension manager and it worked like a charm. Is this my system registry that is corrupted on windows xp? How to test? Thanks.
By the way, for a lot of extension, I have a locket icon. When I installed dict-fr etc, the icon changed to multiple people or to one person. There is some lock on the extensions?
Comment 3 reussandras 2011-08-02 01:04:25 UTC
btw, the solution happened after reinstalling 3.4.2 (it works probably for 3.4.1 too)
Comment 4 reussandras 2011-08-02 01:21:28 UTC
the steps I made:
0. initial state: 3.4.1-> spellcheck is working
1. install 3.4.2 on 3.4.1 ->no spellcheck, any language in language modules
2. uninstall 3.4.2
3. reinstall 3.4.1 ->no spellcheck, no language modules
4. uninstall 3.4.1
5. reinstall 3.4.2 ->no spellcheck, no language modules
6. zipped and installed with extensionmanager needed language from share/extensions
7. it works fine ->happy end
Comment 5 vitriol 2011-08-02 01:37:51 UTC
OK, it's a duplicate of Bug 37195. See comment 24 for a workaround:

https://bugs.freedesktop.org/show_bug.cgi?id=37195#c24

*** This bug has been marked as a duplicate of bug 37195 ***