Bug 39740 - FORMATTING Calc Cell bottom border line through dot NET 4 automation
Summary: FORMATTING Calc Cell bottom border line through dot NET 4 automation
Status: CLOSED DUPLICATE of bug 42784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 RC2
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-01 18:45 UTC by Lt Col RDS Chauhan
Modified: 2012-01-27 10:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lt Col RDS Chauhan 2011-08-01 18:45:39 UTC
My dot net 4 application opens a Office file to add data and format cells.  This application works fine with Open Office but with Libre Office 3.4.2, the bottom line border format of cell is missing.  There are no exceptions thrown.
Comment 1 Jeffrey 2011-08-02 07:41:47 UTC
I'm sorry but this may be a very obvious problem for you, but it would be appreciated if you could provide more information on the bug to help the community.

For example:

-Screenshots of the problem
-Steps to reproduce the bug
-.ods document of the bug

As for now, I am using the Borders button on the Formatting toolbar.

1. View->Toolbars->Formatting (Make sure it is on)
2. Click on the "Borders" button, or make it visible first by clicking the drop down button at the end of the toolbar.
3.Highlight cells with data and select the bottom border 2nd one from left, 2nd one down from drop down. It works fine for me.

Is this what you are talking about? If so, I cannot reproduce it.

Running on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
Comment 2 Lt Col RDS Chauhan 2011-08-02 12:51:35 UTC
(In reply to comment #1)
> I'm sorry but this may be a very obvious problem for you, but it would be
> appreciated if you could provide more information on the bug to help the
> community.
> 
> For example:
> 
> -Screenshots of the problem
> -Steps to reproduce the bug
> -.ods document of the bug
> 
> As for now, I am using the Borders button on the Formatting toolbar.
> 
> 1. View->Toolbars->Formatting (Make sure it is on)
> 2. Click on the "Borders" button, or make it visible first by clicking the drop
> down button at the end of the toolbar.
> 3.Highlight cells with data and select the bottom border 2nd one from left, 2nd
> one down from drop down. It works fine for me.
> 
> Is this what you are talking about? If so, I cannot reproduce it.

I'm please not talking about formatting Calc cell directly from Calc itself.
I have a .NET 4.0 Windows application which does so. This windows application of mine works fine with Open Office.  But while automating Libre Office with the same application, every thing works cprrectly except that bottom line border format of Calc cells does not takes place.

> 
> Running on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.
Comment 3 walid 2011-09-15 02:58:21 UTC
The problem still exists in Libre-office 3.4.3

The following Code (written in Foxpro) Draws Borders on Range B2:F6
The borders are drawn Correctly on Libre-office 3.3.1 but on 3.4.3 The Borders are not drawn.
The code is not hard to understand and I suppose the same problem on dot Net or any other COM programming :


&& ---Declare Variables ---
Local Array aProperty[1]
Local oServiceManager ,oDesktop , CalcObj , Sheet1  
Local aLineBorder , aBorder 


oServiceManager = Createobject( "com.sun.star.ServiceManager" )
oDesktop = oServiceManager.createInstance( "com.sun.star.frame.Desktop")
Comarray( oDesktop, 10 ) && Tells foxpro to pass array as zero based into that object


aProperty[1] = oServiceManager.Bridge_GetStruct( "com.sun.star.beans.PropertyValue" )
aProperty[1].Name = "Hidden"
aProperty[1].Value = .F.

CalcObj = oDesktop.LoadComponentFromUrl( "private:factory/scalc", "_blank", 0, @aProperty)
Sheet1 = CalcObj.getSheets().getByIndex( 0 )


aLineBorder = oServiceManager.Bridge_GetStruct("com.sun.star.table.BorderLine")
aLineBorder.Color = Rgb(255, 0, 0)
aLineBorder.InnerLineWidth = 0
aLineBorder.OuterLineWidth = 26
aLineBorder.LineDistance = 24

aBorder = oServiceManager.Bridge_GetStruct("com.sun.star.table.TableBorder")
aBorder.IsTopLineValid = 1
aBorder.IsBottomLineValid = 1
aBorder.IsLeftLineValid = 1
aBorder.IsRightLineValid = 1
aBorder.IsHorizontalLineValid = 1
aBorder.IsVerticalLineValid = 1

aBorder.TopLine = aLineBorder
aBorder.BottomLine = aLineBorder
aBorder.LeftLine = aLineBorder
aBorder.RightLine = aLineBorder
aBorder.HorizontalLine = aLineBorder
aBorder.VerticalLine = aLineBorder

Sheet1.getCellRangeByPosition(1,1,5,5).tableBorder = aBorder
Comment 4 Olivier Hallot 2011-09-15 03:18:34 UTC
Please give a spin to BorderLine2:

http://api.libreoffice.org/docs/common/ref/com/sun/star/table/BorderLine2.html
Comment 5 walid 2011-09-19 00:54:28 UTC
(In reply to comment #4)
> Please give a spin to BorderLine2:
> 
> http://api.libreoffice.org/docs/common/ref/com/sun/star/table/BorderLine2.html

I Tested the BorderLine2 , it Did Not work 

Please Mark The "Importance" of this Issue as Critical ,
becuase of this issue, I am stuck with 3.3 , I can not upgrade to 3.4
Comment 6 Stefan Knorr (astron) 2011-10-27 14:21:24 UTC
Walid and everyone else, please don't be mad at me, but I am marking this problem down in importance, because it is not a crash or a freeze. I recognise this is a major problem for you, but to the majority of LibO users it is probably not.
Please also know that I am not officially affiliated with TDF (so don't blame them for my action).
Comment 7 Björn Michaelsen 2011-12-23 12:24:01 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 Michael Stahl (CIB) 2012-01-27 10:04:36 UTC
another Calc API BorderLine bug...
Comment 9 Eike Rathke 2012-01-27 10:35:16 UTC
I'm pretty confident that this has the same cause as bug 42784.

*** This bug has been marked as a duplicate of bug 42784 ***