Bug Hunting Session
Bug 39743 - Install overwrites newer versions of fonts
Summary: Install overwrites newer versions of fonts
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
: 111330 115243 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-01 23:46 UTC by dlasher
Modified: 2018-04-06 00:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dlasher 2011-08-01 23:46:52 UTC
The installer does not check whether newer versions of the included fonts are already installed. Therefore the latest build of DejaVu fonts 2.33 were overwritten by version 2.32, and Liberation Sans Narrow 1.07 was overwritten by 1.06.

I had reported this bug to OpenOffice.org in 2009, but it wasn't fixed by them either.
http://openoffice.org/bugzilla/show_bug.cgi?id=98906
Comment 1 Andras Timar 2011-12-13 04:42:48 UTC
Not a real fix, but it is at least a mitigation of damage: LibreOffice 3.4.5 and 3.5 will contain DejaVu 2.33 and Liberation 1.07.1.
Comment 2 Björn Michaelsen 2011-12-23 12:29:45 UTC Comment hidden (spam)
Comment 3 QA Administrators 2015-01-05 17:52:38 UTC Comment hidden (obsolete)
Comment 4 dlasher 2015-05-28 10:11:09 UTC
Since LO 4.4, Windows 7
Comment 5 Buovjaga 2018-03-03 18:38:50 UTC
*** Bug 115243 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2018-03-03 18:38:58 UTC
*** Bug 111330 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2018-03-03 18:39:18 UTC
Resurrecting per dupes.
Comment 8 Andras Timar 2018-03-31 10:39:14 UTC
Hopefully Mike Kaganski fixed this once and for all.
https://cgit.freedesktop.org/libreoffice/core/commit/?id=c91f70f9b0129685737260c04a2e347726f1dedf
Comment 9 Mike Kaganski 2018-03-31 12:01:11 UTC
Some background FYI.

At the time of filing the issue, LibreOffice MSI installer didn't contain font version data, and thus unconditionally copied its fonts. Then, in fix for Bug 76239 (which was actually a dupe for this), versions started to be written to MSI, and so installer should have not downgraded fonts. But the fix was insufficient due to then-lacking of proper library that would correctly parse font files (a workaround was imperfect), so some of fonts were either not processed (otf), or report wrong version (usually unconditional 1.0).

The duped bug 115243 is the example of the latter, where the font would have wrong version 1.0 in our MSI DB, while actual version is 0.111, which is less that 1.0, thus LibreOffice assumed to have a later version and "upgraded" with actually lover version.

So, as Andras pointed out, we hope to get rid of the problem now since we fixed bug 116581, and Khaled Hosny helped finding the library that reports versions properly. Any future problems of this kind should be reported separately, since it would be bugs in new functionality, as opposed to this one filed against then-absent functionality.