Download it now!
Bug 39807 - LibO not show ooxml in fileopen dialog with selected file type
Summary: LibO not show ooxml in fileopen dialog with selected file type
Status: RESOLVED DUPLICATE of bug 49724
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium minor
Assignee: Korrawit Pruegsanusak
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-03 09:08 UTC by Korrawit Pruegsanusak
Modified: 2012-06-08 20:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2011-08-03 09:08:12 UTC
LibreOffice doesn't show the ooxml format (docx, xslx, pptx) in fileopen dialog after selecting appropriate file type, though it can be opened.

Step to reproduce:
1. Create .doc and .docx file, for the ease let them in the same folder
2. LibreOffice > File > Open
3. In "Files of Type:" dropdown, select "Text Documents"
4. Notice that there is .doc shown, but no .docx shown
5. Repeat step 1-4 with .xls/.xlsx/"Spreadsheets" and .ppt/.pptx/"Presentations", the same result occurs.

Workaround:
A. Select "All files (*.*)" or "Microsoft Word 2007 XML (*.docx; *.docm)" (or appropriate) OR
B. Type file name into the dialog

Tested and reproducible with [LibreOffice 3.3.3 OOO330m19 (Build:301) tag libreoffice-3.3.3.1] and [LibreOffice 3.4.2 OOO340m1 (Build:203)] on
Windows XP. So I chose the earliest version per http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 1 Joachim Nuyttens 2011-08-19 12:37:38 UTC
Confirmed. Same issue in LibreOffice 3.3.4.1 OOO330m19 (build 401) on MS Windows 7 and on Debian Wheezy.
Comment 2 Joachim Nuyttens 2011-08-19 12:39:33 UTC
Confirmed. Same issue in LibreOffice 3.3.4.1 OOO330m19 (build 401) on MS Windows 7 and on Debian Wheezy.
Comment 3 Björn Michaelsen 2011-12-23 13:23:10 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 Korrawit Pruegsanusak 2012-06-03 05:30:59 UTC
I think I know how to fix it. A record for me & others:

In filter/source/config/fragments/filters/, select the filter that you want to add, for example calc_MS_Excel_2007_XML.xcu. In there, we have

<node oor:name="Calc MS Excel 2007 XML" oor:op="replace">

Copy oor:name, in this case "Calc MS Excel 2007 XML", and append it to a proper filter in officecfg/registry/data/org/openoffice/Office/UI.xcu

After build/install, this file will be in path-to-install/share/registry/main.xcd. To test this after build, you can edit this file, then restart libo to see the result.

Assigning to me, now the problem is: do we need to add all ooxml-related filter?
Comment 5 Korrawit Pruegsanusak 2012-06-03 05:33:23 UTC
Oh well, just found bug 49724
Comment 6 Korrawit Pruegsanusak 2012-06-08 20:47:44 UTC
Alberto fixed this

*** This bug has been marked as a duplicate of bug 49724 ***