Bug Hunting Session
Bug 39825 - Does not find Firefox profile for digital certificate signing
Summary: Does not find Firefox profile for digital certificate signing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 04:13 UTC by Andreas Berger
Modified: 2013-10-07 08:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Contains macro to verify the certificate path - don't be alarmed. (45.58 KB, application/vnd.oasis.opendocument.text)
2012-04-21 06:07 UTC, Ferry Toth
Details
picture of new options and dialog (74.50 KB, image/png)
2012-04-27 03:17 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Berger 2011-08-04 04:13:49 UTC
When I try to sign a document with a digital certificate the dialog comes up empty.

caolan over at #libreoffice on freenode pointed me towards http://wiki.services.openoffice.org/wiki/Certificate_Detection which mentions "export MOZILLA_CERTIFICATE_FOLDER=~/.mozilla/firefox/<profile>" and this workaround works. 

It's a rather annoying issue tho, and I'm not sure if it's down to packaging (cant find anything on Launchpad/Ubuntu) but this should work properly for all distros by default imo.

Since I'm not a coder I don't know how the detection is done, but the info is at least accessible in ~/.mozilla/firefox/profiles.ini so it seems like LibreOffice should be able to just look that up and everything should work fine :)
Comment 1 Caolán McNamara 2011-08-04 04:15:37 UTC
note I've a vague memory of making this work for the system-mozilla case with the stripped down simple profile finder. If I'm right there then we could use that code for all cases, and reduce dependency on that internal mozilla as a very good side effect.
Comment 2 Caolán McNamara 2011-08-04 04:38:15 UTC
ob question, what LibreOffice are you using ?, i.e. from where
Comment 3 Andreas Berger 2011-08-04 04:39:52 UTC
Ugh, that was silly of me to forget. 
This is on Ubuntu 11.04 using LibreOffice 3.3.2 that comes with the distro.
Comment 4 Björn Michaelsen 2011-12-23 12:21:23 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Ferry Toth 2012-04-21 06:06:50 UTC
I just found the problem on my system. I had at some point installed Thinderbird, although I removed that later (Kubuntu).

The .thunderbird folder still existed and there were no certificates there.

I will attach a document with script that can help debug which certificate store is used by LO.

Of course it would e useful if LO would select the correct store for the Tools Settings menu (similar to selecting the correct JRE).

Ferry
Comment 6 Ferry Toth 2012-04-21 06:07:39 UTC
Created attachment 60415 [details]
Contains macro to verify the certificate path - don't be alarmed.
Comment 7 Not Assigned 2012-04-27 03:16:58 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=207313157688d79cb0d53e920a03423c81a7bc23

Resolves: fdo#39825 Make detection of certificate folder ui-configurable
Comment 8 Caolán McNamara 2012-04-27 03:17:54 UTC
Created attachment 60657 [details]
picture of new options and dialog
Comment 9 Caolán McNamara 2012-04-27 03:19:13 UTC
Added some ui stuff to let you pick the right one, or add one, if for some reason the auto-detection doesn't work out.

If there's some other bug still hidden here, that should help flush it out.
Comment 10 Ferry Toth 2013-10-07 08:12:51 UTC
This great, thanks so much.

For completeness: LibO for windows uses windows certificate store always. The macro in the attached document does not know this and reports the wrong certificate store.