Bug 39830 - Need to select decimal separator when opening a csv file
Summary: Need to select decimal separator when opening a csv file
Status: RESOLVED DUPLICATE of bug 39829
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 07:52 UTC by Nicolas Mailhot
Modified: 2014-11-16 23:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2011-08-04 07:52:46 UTC
The import csv dialog should let the user specify the decimal separator used by numbers inside this csv, since far too many programs output numbers with a dot separator, even when the text fields are in a language used in countries that use period as decimal separator.

This is just as important as being able to specify the value separator or the file encoding.
Comment 1 m.a.riosv 2011-08-04 15:51:07 UTC
It's possible do it.
In the import window, in select the columns with english numbers, then in fields - type of column, select Englis US
Comment 2 m.a.riosv 2011-08-04 15:52:48 UTC
*** Bug 39829 has been marked as a duplicate of this bug. ***
Comment 3 bug_freedesktop 2011-08-07 23:30:14 UTC
IMHO 
* selecting "US English" on a per column basis is not very user friendly - usually it will concern all columns
and 
* not intuitive at all - please call it what it is "dot / comma decimal separator"

* in 3.4.2 selecting "SU English" does not   import decimal dot correctly

it should aslo be possible to select as thousand separator
Comment 4 Milan Bouchet-Valat 2011-09-26 03:34:20 UTC
It's probably possible to detect the decimal separator automatically. If we find "." surrounded by numbers in the file, we can assume it's the decimal separator. Same for ",". The only complex point is that one needs to handle quoting and conflicts in case the CSV separator is the same as the decimal one, but that's not impossible.
Comment 5 Jiri Bohac 2011-10-27 05:45:42 UTC
Also, selecting "US English" is not always what you need. You may actually be running LO with a US English locale and you want to open a CSV file in another language.

I think both the thousand separator and the decimal separator should be configurable.
Comment 6 Björn Michaelsen 2011-12-23 12:21:18 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 anonim 2012-01-02 12:55:29 UTC
We have been waiting for this many years! Please fix this as this is very important in multilangual environments. Please implement it as in MS Excel where we can specify thousand separator and decimal separator. Guessing or suggestions to use "US English" is not appropriate because we receive files in every possible combination of separators, e.g, space or apostroph as thousands separator and comma or dot as a decimal separator.
Comment 8 V Stuart Foote 2014-11-16 23:21:07 UTC
LibreOffice function is correct either selecting the Language (and its number formatting) of the source text being imported to Calc, or setting the column type in the Text Import dialog to US English.

Not a Bug.

But, closing as Duplicate of 39829 which is an enhancement request to provide additional options in formatting numbers being imported to Calc.

*** This bug has been marked as a duplicate of bug 39829 ***