Bug Hunting Session
Bug 39837 - New behavior of calc?
Summary: New behavior of calc?
Status: RESOLVED DUPLICATE of bug 37860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 09:39 UTC by Herbert Geiger
Modified: 2012-03-20 03:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example for the reported bug (7.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-08-04 09:49 UTC, Herbert Geiger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Herbert Geiger 2011-08-04 09:39:31 UTC
does calc now recognize the difference between nothing and anything?
in the attachment line 1 adding empty a + empty b results in 0 (case anything)
in the attachment line 2 adding empty a + empty b results in an error  (case nothing)
the format for all cells ist the same.
in line 1 a and b are "virgin".
in line 2 a and b were purged by using the space-bar.
Comment 1 Herbert Geiger 2011-08-04 09:49:58 UTC
Created attachment 49925 [details]
Example for the reported bug
Comment 2 Oliver Brinzing 2011-08-04 10:02:02 UTC
seems to be a dup of 

https://bugs.freedesktop.org/show_bug.cgi?id=37860
Formula returns #VALUE in 3.4RC2 but works as expected in 3.3
Comment 3 m.a.riosv 2011-08-04 15:44:30 UTC
But an space not is an empty cell.
Comment 4 Jeffrey 2011-08-04 19:57:48 UTC
This is reproducible on LibreOffice 3.4  340m1(Build:103), but I do not think it is a problem because like mariosv said, a space is not an empty cell, and also if you remove the spaces, LO SUM functions as expected.
Comment 5 Herbert Geiger 2011-08-05 03:48:52 UTC
try to think/feel like a simple user of a chartprogram.
in his point of view there is no difference between a cell with space(s) and a cell without anything. both type of cells have a numeric format and are added.
the result of adding two "empty" cells should be zero and not "value". thats the behavior the user expects.
have you ever tested this case with another chartprog?

br
Comment 6 m.a.riosv 2011-08-05 17:30:30 UTC
To my think/feel this is the right way.
What is the meaning of space, empty or zero?.
Could be with a simple A1+B1 no problem, but what happen with for example AVERAGE(A1:B1) or COUNT(A1:B1)
or in a chart representation, is a zero o without data.
The better is avoid any misinterpretation.
Comment 7 Björn Michaelsen 2011-12-23 12:29:13 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 jkonecny 2012-01-25 11:22:59 UTC
I tested on 3.5.0beta2.  (A cell with a space in it) + 1 = #VALUE!  At first I did not like this because in OpenOffice (A cell with a space in it) + 1 = 1.  Then I had an OpenOffice user using the space bar to clear out cell data.  This looks ok in OpenOffice however when saved as an XLS sheet and sent to an excel user it appears as #VALUE!.  So the excel user thinks that OOo has a bug in it.  Now with LO behaving the same as excel I think that is better.  An LO user would have seen the #VALUE! just like an excel user.  This provides better compatibility between LO/excel.  I think this bug should be marked INVALID.
Comment 9 Philipp Gassmann 2012-03-20 03:59:38 UTC

*** This bug has been marked as a duplicate of bug 37860 ***