Bug Hunting Session
Bug 39864 - Preview of index is incomplete
Summary: Preview of index is incomplete
Status: RESOLVED DUPLICATE of bug 40948
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) All
: medium major
Assignee: Eduardo Moreno
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-05 10:12 UTC by Eduardo Moreno
Modified: 2012-03-03 14:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File created in Windows 7 with LibO 3.4.2 Spanish translation (13.77 KB, application/vnd.oasis.opendocument.text)
2011-08-05 10:12 UTC, Eduardo Moreno
Details
Screen shot showing TOC preview on 3.3.3 and 3.4.2 (14.39 KB, image/png)
2011-08-07 05:38 UTC, RGB
Details
Index and Tables, not more fiels (37.67 KB, image/png)
2011-12-27 07:07 UTC, Eduardo Moreno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Moreno 2011-08-05 10:12:15 UTC
Created attachment 49969 [details]
File created in Windows 7 with LibO 3.4.2 Spanish translation

Bug test in Windows 7 (Virtualbox) and Ubuntu 10.04.
I have a document and try to make a Index. In preview not see the number page.
Comment 1 RGB 2011-08-07 05:38:29 UTC
Created attachment 50010 [details]
Screen shot showing TOC preview on 3.3.3 and 3.4.2

I can confirm the problem. As you can see on the attached screen shot, on TOC preview LibO 3.4.2 (right on the screen shot) do not show all the details you can see on 3.3.3 (left on the screen shot). 
I see the problem with a 64 bits LibO vanilla build on openSUSE 11.4 with KDE SC 4.6.5 and with both UI language, English and Spanish. 
Sometimes, an almost complete preview flash for a second when dialogue is opened, but soon after it shows as on the screen shot.
Setting a preview scale to 20 % (right click over the preview) shows page numbers but at that scale preview is almost useless...
Anyway, it seems that the preview behaviour changed on 3.4.x series, because with that 20 % you can see "real pages" on 3.4.2 while 3.3.3 only change the size of the objects, not the "canvas". Is, maybe, this change the responsible for the uncompleted preview?
Comment 2 RGB 2011-08-07 05:55:41 UTC
Additional info: if at 20 % you do a right click → Downwards a couple of times, the missing objects appears for a while on second page, but as soon as you do right click → Upwards they disappears again, so this is clearly a rendering problem.
Comment 3 Björn Michaelsen 2011-12-23 12:27:09 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 RGB 2011-12-23 17:01:43 UTC
The problem is present on 3.5 beta2.
Comment 5 Eduardo Moreno 2011-12-27 07:07:57 UTC
Created attachment 54852 [details]
Index and Tables, not more fiels

I can't add more fields or correct the format of the entries in the index becouse the buttons with left arrow not work.
Comment 6 manj_k 2012-03-03 14:45:34 UTC
(In reply to comment #5)
> Created attachment 54852 [details]
> Index and Tables, not more fiels
> 
> I can't add more fields or correct the format of the entries in the index
> becouse the buttons with left arrow not work.

I am assuming that it is your initial intention, so:

Already reported (and added to 'LibreOffice 3.4 most annoying bugs') as 
'Bug 40948 - UI · EDITING: Hyperlink on page number in a Table of contents impossible via right button (mouse click)'.
[ Some workarounds available in bug 40948  ;) ]

*** This bug has been marked as a duplicate of bug 40948 ***