Download it now!
Bug 39865 - CRASH on FILEOPEN html file with a https:// image reference
Summary: CRASH on FILEOPEN html file with a https:// image reference
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4 Daily
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-05 12:08 UTC by Petr Cerny [:hrosik]
Modified: 2011-12-28 05:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file causing crash (519 bytes, text/xml)
2011-08-05 12:08 UTC, Petr Cerny [:hrosik]
Details
strace log of the crash (1.98 MB, application/octet-stream)
2011-08-09 09:58 UTC, Petr Cerny [:hrosik]
Details
crash backtrace (21.58 KB, application/octet-stream)
2011-08-09 10:16 UTC, Petr Cerny [:hrosik]
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cerny [:hrosik] 2011-08-05 12:08:24 UTC
Created attachment 49971 [details]
file causing crash

testcase attached (boiled down to a reasonably small and still almost valid xhtml).
Crashes all apps in the suite except for calc when called as a specific app (oowriter, ...).
Comment 1 noname 2011-08-06 04:50:44 UTC
Unconfirmed with [Win2K LibreOffice 3.4.2 OOO340m1 (Build:203)].

btw: is the background suppost to be yellow ? Can't seems to make it anything else (another bug ?).
Comment 2 Petr Cerny [:hrosik] 2011-08-09 09:53:18 UTC
(In reply to comment #1)
> Unconfirmed with [Win2K LibreOffice 3.4.2 OOO340m1 (Build:203)].
> 
> btw: is the background suppost to be yellow ? Can't seems to make it anything
> else (another bug ?).

No, unless it is your default background colour I guess.
Comment 3 Petr Cerny [:hrosik] 2011-08-09 09:58:56 UTC
Created attachment 50074 [details]
strace log of the crash
Comment 4 Petr Cerny [:hrosik] 2011-08-09 10:16:47 UTC
Created attachment 50075 [details]
crash backtrace

... might be incomplete due to some missing debuginfo packages
Comment 5 Rainer Bielefeld Retired 2011-09-06 11:54:59 UTC
NOT reproducible with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  3b32204-7f92fce-2ba0a9f)]" and reporter's sample document.

My test:
1. dwonloaded attachment with MS IE (all other browsers want to open 
   document directly in browser)
2. Start LibO (Start Center appears)
3. Open new Writer Document
4. Menu 'File -> Open - Browse for sample document -> <open>
   Document opens in WRITER, picture is replaced by placeholder, but no crash.
   Picture URL: 
   <http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash>

The same result with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]".

Also no crash with a LibO 3.4.2RC2 based daily from end of July, but strange: with that version the picture is shown correctly. There the picture URL in document is <https://www.adobe.com/images/shared/download_buttons/get_flash_player.gif> Completely different!

Related to the problem? 

No crash here, so Linux related?

Petr Cerny:
Can you confirm my observations? 
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary, because
  you can not know what others will see with your sample
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (What Linux / Version)?
  -- concerning your LibO version and localization (UI language, 64bit build?)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  -- With what other Versions the problem was not visible
  -- everything else crossing your mind after you read a.m. URL

May be you can test <http://wiki.documentfoundation.org/BugReport_Details> for submitting bug reports?

Please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information, that the problem will be reproducible with information you can provide or that your enhancement request will be accepted!

Thank you!
Comment 6 Petr Cerny [:hrosik] 2011-09-08 07:07:10 UTC
(In reply to comment #5)
Still happens on openSUSE/Factory, LibO 3.4.2.5.

Happens both when running from command line 'oowriter <testcase>' or using File -> Open dialog.

I'll try to try on other machine as well.

> 1. dwonloaded attachment with MS IE (all other browsers want to open 
>    document directly in browser)

I don't know about other browsers, but in the Mozilla ones when you click on a link while holding <Shift> a "Save target as" dialog appears.

> Please file Bug reports with status UNCONFIRMED if your are not absolutely sure
> that you contributed all required background information, that the problem will

AFAIR I haven't touched the status field, so you should perhaps sort this out with BFO services team.
Comment 7 Petr Cerny [:hrosik] 2011-09-08 07:30:26 UTC
3.4.2 on SUSE Linux Enterprise Desktop seems to work. Could be problem in dependencies.

Adding SUSE LibO packages maintainer to CC.

> 1. dwonloaded attachment with MS IE (all other browsers want to open 
>    document directly in browser)
Or right-click and "Save Link Target As"
Comment 8 tester8 2011-10-08 14:25:57 UTC
NOT reproduced with

LO 3.4.3 OOO340m1 (Build:302)
Ubuntu 10.04.3 x86
Linux 2.6.32-34-generic Russian UI

Image is shown correctly.
Seems to be SUSE problem.
Comment 9 Björn Michaelsen 2011-12-23 12:27:33 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 Björn Michaelsen 2011-12-23 16:59:41 UTC
needinfo keyword redundant by needinfo status.
Comment 11 Jan Holesovsky 2011-12-28 05:50:08 UTC
Seems fixed in 3.5.0 Beta2.