Download it now!
Bug 39926 - "No symbol" for a single data point sets the symbol to default square
Summary: "No symbol" for a single data point sets the symbol to default square
Status: RESOLVED DUPLICATE of bug 126033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2011-08-08 05:17 UTC by Regina Henschel
Modified: 2019-09-01 09:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ods created as explained in 3.5.2 (13.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-04-11 04:29 UTC, sasha.libreoffice
Details
Screenshot of the example file in 6.0.7 and current master (326.21 KB, image/png)
2019-09-01 09:27 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2011-08-08 05:17:42 UTC
(1) Generate a simple XY-chart with lines and symbols for example from
x   y
1   1
2   1
3   3
4   2
(2) Set the data series to red and to show diamonds as symbol.
(3) Select one data point (first activate data series, then click on one data point)
(4) Open object property dialog. Make sure its title is "Data Point for Data Series 'y'".
(5) Open "Select" and choose "No symbol". Notice the symbol in the preview vanishes. Close dialog.

Expected behavior: The data point has no symbol.
Seen behavior: The data point has the default symbol "black square".

This was OK in OOo2.4.3. It is broken at least since OOo3.1.
Comment 1 sasha.libreoffice 2012-04-11 04:26:39 UTC
Reproduced in 3.3.4 and 3.5.2 on Fedora 64 bit
Comment 2 sasha.libreoffice 2012-04-11 04:29:47 UTC
Created attachment 59800 [details]
ods created as explained in 3.5.2
Comment 3 sasha.libreoffice 2012-04-11 04:32:00 UTC
http://odf-validator.rhcloud.com/ complains about attachment:
Chart point problem.ods/Object 1/content.xml[52,109]: Error: tag name "chartooo:coordinate-region" is not allowed. Possible tag names are: <axis>,<floor>,<light>,<series>,<stock-gain-marker>,<stock-loss-marker>,<stock-range-line>,<wall>
Comment 4 A (Andy) 2014-10-03 16:16:03 UTC
Reproducible with LO 4.3.2.2 (Win 8.1)
Comment 5 QA Administrators 2015-10-14 19:57:43 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2016-01-30 13:48:27 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 9784ff3d878eaa21491fbd779e57d7d4710f5449
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-30_01:31:57
Locale: fi-FI (fi_FI)
Comment 7 QA Administrators 2017-10-23 13:58:18 UTC Comment hidden (obsolete)
Comment 8 Regina Henschel 2017-11-06 00:12:38 UTC
The error still exists in Version: 6.0.0.0.alpha0+
Build ID: 6c68f38bc28bb55a4f0d53b8f38957516d3935d1
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-09-04_22:05:26
Locale: de-DE (de_DE); Calc: group
Comment 9 Regina Henschel 2018-11-06 15:36:07 UTC
The error still exists in Version: 6.2.0.0.alpha1+ (x64)
Build ID: f825e6d4082c0d0beb1c95b881f6a2ee9bfc9161
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-05_00:20:26
Locale: de-DE (en_US); Calc: CL
Comment 10 Gabor Kelemen 2019-09-01 09:27:03 UTC
Created attachment 153790 [details]
Screenshot of the example file in 6.0.7 and current master

On the right side I added data series labels to visualize better the hidden data points.

This seems to be fixed by commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2783a34899379dae84889c924e49481631280ab1
Comment 11 Gabor Kelemen 2019-09-01 09:27:33 UTC

*** This bug has been marked as a duplicate of bug 126033 ***