Bug Hunting Session
Bug 39999 - Changing spelling preferences requires application restart
Summary: Changing spelling preferences requires application restart
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium minor
Assignee: Szabolcs Dézsi
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-11 02:53 UTC by Urmas
Modified: 2012-05-19 06:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2011-08-11 02:53:03 UTC
When spelling preferences, for example check uppercase words, are changed in preferences dialog, they are not in effect until application is restarted.
Comment 1 Joachim Nuyttens 2011-08-21 04:57:50 UTC
Confirmed in LibreOffice 3.3.4.1 OOO330m19 (build 401) on Debian Wheezy.

When changing the option 'check uppercase words' (Language settings > Writing Aids > Options). The changes to this setting become effective only after a complete restart of LibreOffice, closing and re-opening the document is not sufficient.

I could not identify any other of the writing aids options affected by this problem. The following options are for sure NOT affected by this issue, changes become effective immediately for:
- 'check spelling as you type'
- 'check words with numbers'
- different hyphenation settings
Comment 2 Stephan Hennig 2011-10-04 09:34:35 UTC
(In reply to comment #1)
> Confirmed in LibreOffice 3.3.4.1 OOO330m19 (build 401) on Debian Wheezy.
> 
> When changing the option 'check uppercase words' (Language settings > Writing
> Aids > Options). The changes to this setting become effective only after a
> complete restart of LibreOffice, closing and re-opening the document is not
> sufficient.
> 
> I could not identify any other of the writing aids options affected by this
> problem.

Confirmed with LibreOffice 3.4.3 on Windows XP.
Comment 3 Björn Michaelsen 2011-12-23 13:26:21 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 Not Assigned 2012-04-21 12:48:55 UTC
Szabolcs Dezsi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2bfa5cfdaaa68a3e2bd751cc45955e4ea41f36b

Resolves: fdo#39999: Changing spelling preferences requires application restart
Comment 5 Not Assigned 2012-04-23 00:09:57 UTC
Szabolcs Dezsi committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=563e65eea742df35ab9b620f6384c2918c32915c&g=libreoffice-3-5

Resolves: fdo#39999: Changing spelling preferences requires application restart


It will be available in LibreOffice 3.5.4.