Download it now!
Bug 40009 - Sheet column or row indicators not completely painted in specific file
Summary: Sheet column or row indicators not completely painted in specific file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 40601 41173 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-11 06:13 UTC by Roman Polach
Modified: 2015-03-04 10:05 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
XLS document to open (6.50 KB, application/vnd.ms-excel)
2011-08-11 06:13 UTC, Roman Polach
Details
Screenshot of not-fully painted horizontal header (23.78 KB, image/png)
2011-08-11 06:14 UTC, Roman Polach
Details
Screen capture showing the bug in the sheet (162.03 KB, image/jpeg)
2011-09-03 08:49 UTC, Gabriel
Details
Another example of visual corruption - this is in horizontal header... LibO_3.5.3 (47.69 KB, image/png)
2012-05-10 07:17 UTC, Roman Polach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Polach 2011-08-11 06:13:37 UTC
Created attachment 50124 [details]
XLS document to open

I occasionally see vertical or horizontal
sheet header not fully painted, sometimes
with one small or larger gap, sometimes with
more gaps... Once (in 3.4.2) I saw also
horizontal header painted in mid-screen
(mid-height of sheet).

I made example of reproducibility with gap
in horizontal header - where column B and partially
columns A and C are painted like normal cells
- see attachments: xls document and screenshot.

Reproducibility of this case: Allways.
Way to reproduce is one step only: Open this xls
document in LO 3.4.2
Comment 1 Roman Polach 2011-08-11 06:14:16 UTC
Created attachment 50125 [details]
Screenshot of not-fully painted horizontal header
Comment 2 Jeffrey 2011-08-13 20:56:22 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

Do not know why but only the attachment has a problem. Other files, even xls ones do not seem to cause trouble on my computer. What did you enter into the spreadsheet? Just the text?
Comment 3 Roman Polach 2011-08-14 13:12:37 UTC
The creation steps for this xls file are unknown.
This file contained lot of data before I deleted them.
Comment 4 vitriol 2011-09-03 07:21:19 UTC
*** Bug 40601 has been marked as a duplicate of this bug. ***
Comment 5 vitriol 2011-09-03 07:24:24 UTC
Platform all
Comment 6 Gabriel 2011-09-03 08:49:22 UTC
Created attachment 50871 [details]
Screen capture showing the bug in the sheet
Comment 7 Rainer Bielefeld Retired 2011-09-25 05:00:33 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and still a problem with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]".

@Kohei:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 8 Rainer Bielefeld Retired 2011-09-25 05:02:12 UTC
*** Bug 41173 has been marked as a duplicate of this bug. ***
Comment 9 Roman Polach 2012-05-10 07:17:38 UTC
Created attachment 61370 [details]
Another example of visual corruption - this is in horizontal header... LibO_3.5.3
Comment 10 Cor Nouws 2013-05-17 21:33:29 UTC
(testing in 4033 - also saved as .ods ...)

weird problem :)
I guess it has something to do with the files history ...
Comment 11 QA Administrators 2015-03-04 02:22:37 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 12 Roman Polach 2015-03-04 10:05:15 UTC
While the problem is present in LO 3.5.5, it seems to be
ok in LO 4.4.1 final. So according to
https://bugs.documentfoundation.org/show_bug.cgi?id=40009#
I am setting this bug as WORKSFORME.