Bug Hunting Session
Bug 40036 - U+202E Right-to-Left Override does not display properly
Summary: U+202E Right-to-Left Override does not display properly
Status: RESOLVED DUPLICATE of bug 107204
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2011-08-12 03:14 UTC by phayanaaro
Modified: 2017-10-20 22:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A file displaying the problem. (12.70 KB, application/vnd.oasis.opendocument.text)
2011-08-12 03:14 UTC, phayanaaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description phayanaaro 2011-08-12 03:14:22 UTC
Created attachment 50155 [details]
A file displaying the problem.

The Unicode character U+202E Right-to-Left Override (RLO) should force all text following it to be displayed right-to-left, overriding the normal direction of the script.  Instead, in Writer, Calc, Impress, and Draw, U+202E has no effect on the direction of text and, depending on the font, may display as a box instead of an invisible control character.

Steps to Reproduce:

1) Open any LibreOffice program.
2) Enter the character U+202E (Unicode direct input varies by OS, but Ctrl+Shift+u,202e,return works on most Linux distros).
3) Type in any left-to-right script.
3a) Note that this bug does not appear if a right-to-left script has previously been typed on the same line.

Actual behavior:
Input appears as normal.  U+202E may display as a box.

Expected behavior:
Characters should be displayed from right to left.

Documented in:
LibreOffice 3.3.2 (1:3.3.2-1ubuntu5 from the Ubuntu repository, x64)
LibreOffice 3.3.3 (Fedora)
OpenOffice 3.3 (Windows 7 SP1 x64, 32-bit program)
Comment 1 phayanaaro 2011-08-12 03:22:52 UTC
While switching the paragraph direction to RTL without using an RTL script also enables Right-to-Left Override, the font (by either method) is changed to the default CTL font.
Comment 2 Rainer Bielefeld Retired 2011-08-12 23:46:39 UTC
I see the effect with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]" , also Master and OOo 3.4., but my knowledge is too poor for any conclusion
Comment 3 Rainer Bielefeld Retired 2012-02-26 02:09:58 UTC
@Urmas:
Please leave some information concerning your observations, OS, LibO version, reasons why you confirm that it's a bug, ...
Comment 4 sasha.libreoffice 2012-03-01 06:27:09 UTC
Please, verify if in last version of LibreOffice still reproducible
Comment 5 retired 2013-05-03 21:49:14 UTC
Setting to INVALID, since no further feedback has been provided for over a year.
Comment 6 Urmas 2013-05-04 21:09:33 UTC
The issue is that RLO has no effect unless there are some RTL characters anywhere in the paragraph. There is no justification for this behavior.
Comment 7 Joel Madero 2014-11-06 21:56:23 UTC
I don't see a confirmation in the comments. Urmas if you've confirmed please set the bug to NEW - else moving this to UNCONFIRMED for independent confirmation. Thanks all.
Comment 8 Urmas 2014-11-07 01:00:14 UTC
That still happens in 4.4 master, at least on Windows.
Comment 9 QA Administrators 2016-09-20 10:14:22 UTC Comment hidden (obsolete)
Comment 10 amirimobile 2016-09-20 13:10:56 UTC
Bug is still present on my system:

Debian Linux
Version: 5.2.1.2
Build ID: 1:5.2.1-2
Comment 11 Xisco Faulí 2017-09-29 08:53:35 UTC Comment hidden (obsolete)
Comment 12 Khaled Hosny 2017-10-20 22:06:46 UTC
This works for me, and from bug description I suspect it was the same underlying issue as bug 107204, so marking as duplicate.

*** This bug has been marked as a duplicate of bug 107204 ***