Bug 40053 - [FILEOPEN] Problem opening a csv file, not recognized
Summary: [FILEOPEN] Problem opening a csv file, not recognized
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-13 02:57 UTC by xdmx
Modified: 2013-11-14 16:48 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
the broken file (1.37 KB, text/csv)
2011-08-13 02:57 UTC, xdmx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xdmx 2011-08-13 02:57:02 UTC
Created attachment 50173 [details]
the broken file

I'm using the 3.3.3 release, I had any chance to try this under 3.4.x.

I've created a csv file from a ruby library (fastercsv) and looking at it seems correct, I can also reopen the file with that same library with any problem.

The problem is when I try to open it using calc, usually for csv file is showed the filter view in order to select the separator, quotation, etc. But for this file it doesn't happen, but it open the import options window with the ability to choose just the language and to detect special chars like dates. Obviously the resulting spreadsheet doesn't open correctly (just messed up values)

I attach it here
Comment 1 xdmx 2011-08-13 03:05:22 UTC
Just a small update

The mimetype at the creation/server is set correctly (text/csv)

$ wget "http://localhost.localdomain:3000/27.csv"
--2011-08-13 12:02:33--  http://localhost.localdomain:3000/27.csv
Resolving localhost.localdomain... 127.0.0.1
Connecting to localhost.localdomain|127.0.0.1|:3000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1481 (1.4K) [text/csv]
Saving to: `27.csv'

100%[=================================================================================================================================================================>] 1,481       --.-K/s   in 0s      

2011-08-13 12:02:33 (157 MB/s) - `27.csv' saved [1481/1481]
Comment 2 Björn Michaelsen 2011-12-23 12:34:33 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 13:58:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 13:59:22 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:03:56 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:06:10 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian