Bug 40061 - Merge-Cells doesn't work when recording changes
Summary: Merge-Cells doesn't work when recording changes
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
Depends on:
Blocks: Calc-Merge-Split Calc-Track-Changes
  Show dependency treegraph
Reported: 2011-08-13 10:31 UTC by Li The G
Modified: 2021-01-07 17:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Li The G 2011-08-13 10:31:36 UTC
ubuntu@lapator:~$ uname -a
Linux lapator 2.6.32-33-generic #72-Ubuntu SMP Fri Jul 29 21:07:13 UTC 2011 x86_64 GNU/Linux

Tried merging cells in a spreadsheet with changes being recorded and it didn't work. Tried it in a fresh new spreadsheet and it worked without any problems.  Didn't find any documentation hinting that this is normal behavior.
Comment 1 Jeffrey 2011-08-13 20:25:45 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.
Comment 2 Björn Michaelsen 2011-12-23 12:35:57 UTC Comment hidden (obsolete)
Comment 3 Li The G 2012-01-15 04:11:19 UTC
Ran LibreOffice 3.4.3, OOO340m1 (Build:302) on 
>uname -a
Linux ubuntu-VirtualBox 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
>lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 11.10
Release:	11.10
Codename:	oneiric

and the issue still persists. Merging cells while recording changes is NOT possible.
Comment 4 Kohei Yoshida 2013-03-22 03:02:25 UTC
Actually this is a known limitation.  Setting it to enhancement request.
Comment 5 Charles 2017-03-17 16:53:38 UTC
Bummer... just encountered this ans was coming to report it.

This means that whenever you want to work with merged cells, you have to lose all Changes History. This is really, really bad when the spreadsheet in question is one that holds critical internal documentation that requires changes to be tracked.
Comment 6 Marco Marega 2020-05-02 16:24:16 UTC
I came here, because on the Italian Ask site a user had the same problem, so I searched and found this bug report.
I want to observe that, if recording changes were enabled, he cannot merge cells or even remove sheets.
I tried and reproduced this behavior on my PC, I have version on Linux, don't know the version of the user that posted the question on Ask.