Bug 40120 - MS Word incompatibility with frames (and sometimes tables involved ? - better testing and summary needed.)
Summary: MS Word incompatibility with frames (and sometimes tables involved ? - better...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-15 19:32 UTC by holeung.ng
Modified: 2013-09-01 12:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word document (16.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-08-15 19:33 UTC, holeung.ng
Details
Problem seems evident on MS Word as well. (139.23 KB, image/png)
2011-08-16 05:37 UTC, Jeffrey
Details
docx document with table in frame (14.85 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-01-31 05:10 UTC, sasha.libreoffice
Details
screenshot in MSWord 2007 russian (frame selected) (321.00 KB, image/jpeg)
2012-01-31 05:13 UTC, sasha.libreoffice
Details
docx document without table in frame (beginning of initial document) (12.00 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-01-31 05:14 UTC, sasha.libreoffice
Details
screenshot in MSWord 2007 russian (line selected) (290.22 KB, image/jpeg)
2012-01-31 05:16 UTC, sasha.libreoffice
Details
7 frames done in MSO 2007 (12.98 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-02-06 04:58 UTC, sasha.libreoffice
Details
7 frames done in MSO 2007, saved as odt (7.20 KB, application/vnd.oasis.opendocument.text)
2012-02-06 04:59 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description holeung.ng 2011-08-15 19:32:09 UTC
This Word document is completely screwed up by Writer. Created with Word 2002, opens fine on my computer.
Comment 1 holeung.ng 2011-08-15 19:33:22 UTC
Created attachment 50254 [details]
Word document
Comment 2 Jeffrey 2011-08-16 05:37:36 UTC
Created attachment 50267 [details]
Problem seems evident on MS Word as well.

On LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux. I can see that the vertical column on text is corrupted. Only problem is when I open the Word document, the lines beneath the vertical text is corrupted as well. So I am unsure as to whether the problem is confirm-able. See attachment.
Comment 3 Cor Nouws 2011-08-17 05:02:05 UTC
so close as invalid?
Comment 4 noname 2011-08-17 12:44:37 UTC
Tested with [Win2K OpenOffice.org 3.2.1 OOO320m19 (Build:9505)]
Frame on the second page goes of the page, but is readable.

On [Win2K LibreOffice 3.3.4 OOO330m19 (Build:401)].
Frame on the second page is completely blank.

With both versions, text is corrupt. The Frame problem is something else as it loads correct with abiword.
Comment 5 Cor Nouws 2011-08-17 13:45:38 UTC
thnx for additional testing. Then at least the issue represents a regression from OOo 321 to OOo/LibreOffice 3.3.x and a case for improvement.
Comment 6 Cor Nouws 2011-09-07 13:29:50 UTC
could one of the testers pls try to create a meaningful discription for the issue?
E.g. mentioning frames, or hidden, or ..

Thanks :-)
Comment 7 Björn Michaelsen 2011-12-23 12:31:53 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 sasha.libreoffice 2012-01-31 05:10:32 UTC
Created attachment 56375 [details]
docx document with table in frame
Comment 9 sasha.libreoffice 2012-01-31 05:13:01 UTC
Created attachment 56376 [details]
screenshot in MSWord 2007 russian (frame selected)
Comment 10 sasha.libreoffice 2012-01-31 05:14:45 UTC
Created attachment 56377 [details]
docx document without table in frame (beginning of initial document)
Comment 11 sasha.libreoffice 2012-01-31 05:16:25 UTC
Created attachment 56378 [details]
screenshot in MSWord 2007 russian (line selected)
Comment 12 sasha.libreoffice 2012-01-31 05:30:27 UTC
reproduced in LibO 3.6.0 master
I have splitted initial document into 2 another and added screenshots of both in MsOffice.
In first document problem is with frame, it becomes with wrong size and position
In second document is some another problem
Comment 13 Cor Nouws 2012-02-03 11:22:39 UTC
Hi,

(In reply to comment #12)
> In second document is some another problem

Thanks for the docs and so.
For another issue, can you please add the file to an already existing same issue or write a new one, if needed? thanks - Cor
Comment 14 sasha.libreoffice 2012-02-04 04:44:10 UTC
> and sometimes tables involved ? - better testing and summary needed
What exactly I should text and which information provide? Please, tell. And I try do what I can.

> For another issue
Bug 45447 - Writer FILESAVE: validation of odt not passed
Comment 15 Cor Nouws 2012-02-06 03:02:13 UTC
hi Sacha,

(In reply to comment #14)
> What exactly I should text and which information provide? Please, tell. And I
> try do what I can.

Well, 
    for example  Table in frame show wrong in this or that way
    or other exmaple:  text in frame anchored at e.g. page is not shown

It can be so much more specific then " MS Word incompatibility " ;-)

thanks a lot!
Comment 16 sasha.libreoffice 2012-02-06 04:58:38 UTC
Created attachment 56664 [details]
7 frames done in MSO 2007
Comment 17 sasha.libreoffice 2012-02-06 04:59:34 UTC
Created attachment 56665 [details]
7 frames done in MSO 2007, saved as odt
Comment 18 retired 2013-09-01 12:28:27 UTC
Can someone explain in simple words what the problem is we are trying to solve here?!?

I downloaded both versions of "7 frames done in MSO" and compared them. They look identical to my eyes on OS X 10.8.4, LO 4.2.

Version: 4.2.0.0.alpha0+
Build ID: 9fed8a5e4a4c45d6a08260e9480ca6b43254b120
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-29_07:14:27

Setting to WORKSFORME. Pleae re-open if you disagree.