Bug Hunting Session
Bug 40146 - FILEOPEN xlsx landscape page with interchanged width/height values
Summary: FILEOPEN xlsx landscape page with interchanged width/height values
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-16 09:49 UTC by Orion Poplawski
Modified: 2014-09-03 21:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (66.29 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2011-08-16 09:49 UTC, Orion Poplawski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2011-08-16 09:49:34 UTC
Created attachment 50279 [details]
Sample file

In the attached file, the page layout is set to landscape.  However, LibreOffice 3.4.2 and 3.3.3 default to printing it portrait.  Also, if I try to change to landscape, the top of the document is chopped off.  Using the libreoffice.org rpms on Fedora 15.
Comment 1 Jeffrey 2011-08-16 19:11:53 UTC
Sort of confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

I have a slight variation to this problem. What happens is when I open the file the page preview displays the page as portrait, but page format says the page is in landscape. When I change it to portrait, the page displays as landscape! So it looks like the orientation is reversed.
Comment 2 Scott M. Sanders 2011-09-15 06:34:45 UTC
I also have XLSX documents with orientation set to landscape, they appear as landscape in Excel and oddly enough OpenOffice.org, while LibreOffice shows them as portrait.

But the exact same documents in XLS format appear just fine.

And I am on Windows presently.
Comment 3 Rainer Bielefeld Retired 2011-10-02 10:49:10 UTC
I can confirm that page settings from sample document are not in accordance with LibO standard for reporter's sample and with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

This is not a printing, but a FILEOPEN problem n LibO an A4 landscape page shows in Menu 'Format -> Page':
Width: 297,00mm
Hight: 210,00mm
Radibutton: Landscape

Sample button in LibO shows
Width: 210,00mm
Hight: 297,00mm
Radibutton: Landscape

Width and height are interchanged

Same result with an own document created with Office 2010 by simply creating new document, writing some numbers into some cells and then modifying page orientation from portrait to landscape.

Save as .xlsx will  have to be investigated

Kohei:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Rainer Bielefeld Retired 2011-10-02 10:52:07 UTC
Still a problem  with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]"
Comment 5 Björn Michaelsen 2011-12-23 13:25:16 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 6 Julien Nabet 2014-02-01 15:03:09 UTC
With 4.1 LO sources, preview shows the page with Landscape orientation and format page also shows Landscape.

Any update?
Comment 7 QA Administrators 2014-09-03 21:32:28 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 8 Orion Poplawski 2014-09-03 21:44:02 UTC
This seems to be working okay now with 4.2.6.2