Bug Hunting Session
Bug 40165 - [EDITING] Undo retains overwriting text
Summary: [EDITING] Undo retains overwriting text
Status: RESOLVED DUPLICATE of bug 37405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard: bibisected35 bibisected35older
Keywords: regression
: 40365 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-17 06:06 UTC by c4.smithereens
Modified: 2012-06-28 03:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description c4.smithereens 2011-08-17 06:06:43 UTC
Steps to reproduce:

1. Create an empty presentation.
2. On the title slide, click on a text box to start typing.
3. Type "a".
4. Select "a".
5. Type "b", overwriting "a".
6. Press Ctrl+Z, to undo.

Expected Result:

"b" should be replaced with "a".

Actual Result:

"b" is not replaced but rather "a" is inserted before it, and the cursor rests between them.

Worse, a redo operation at this point is labeled as "Insert", but redoing causes the "a" to be deleted. Although after that the undo is labeled as "Insert" again and undoing brings it back.
Comment 1 Korrawit Pruegsanusak 2011-08-25 07:01:15 UTC
*** Bug 40365 has been marked as a duplicate of this bug. ***
Comment 2 Rainer Bielefeld Retired 2011-09-12 22:03:31 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

Worked fine with [Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]", so regression!

@Radek:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 3 Björn Michaelsen 2011-12-23 13:26:34 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 Clifton 2012-05-13 12:12:02 UTC
This is also happening on the latest version 3.5.3.2 on Ubuntu 12.04 LTS.
Enter some text. Replace some of that text. and click undo. the text that was used to replace will remain and previous text shown.
Comment 5 Rainer Bielefeld Retired 2012-05-13 23:04:58 UTC
Related to "Bug 45749 - EDITING: Undo stack with wrong sort order and incomplete"?
Comment 6 Ivan Timofeev (retired) 2012-06-28 03:29:53 UTC

*** This bug has been marked as a duplicate of bug 37405 ***