Bug Hunting Session
Bug 40179 - IDE: UNDO does not revert inserted text
Summary: IDE: UNDO does not revert inserted text
Status: RESOLVED DUPLICATE of bug 37405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-17 12:06 UTC by Roman Polach
Modified: 2012-06-28 03:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Polach 2011-08-17 12:06:09 UTC
When I use BASIC macro editor and
I insert some text and delete other text,
then UNDO feature reverts deletion but
never the text insertion.

Step to reproduce:
1. Open some spreadsheet file with BASIC
   macro procedures/functions
2. insert some text by typing on keyboard
3. delete some other text
4. insert some text by typing on keyboard
5. delete some other text
6. try undo all actions...

Result: while all previously deleted text
shows up, no previously typed text is removed.
Thus, the macro code is mess and is not equal
to state between steps 1 and 2.
Comment 1 Rainer Bielefeld Retired 2011-08-18 00:44:49 UTC
I failed to reproduce the problem with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]", but may be I did not understand all details of the report.

Might be a DUP of "Bug 37405 - Undo is broken in Basic IDE"?

@Reporter
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> ?
Then please:
- Write a meaningful Summary
- Attach a sample document 
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary, because
  you can not know what others will see with your sample
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem. For example do not write "type some text", but "Click behind word "xaz", tpye "abc"
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS
  -- concerning your and localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read a.m. URL

Can you please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide? 

Thank you for aour attention!
Comment 2 Korrawit Pruegsanusak 2011-08-26 04:58:45 UTC
I think I've caught it.

Reproducible with LibreOffice 3.4.2 OOO340m1 (Build:203) Windows XP
Step to reproduce:
1. Open BASIC editor
2. type "qwerty"
3. delete "rty" by pressing BackSpace 3 times, the remaining is now "qwe"
4. type "asdf" to the back (appending it), the text is now "qweasdf"
5. press Ctrl+Z to undo
Expected: "asdf" will be deleted from back to front, in backward order like this: "qweasdf" > (Ctrl+Z) > "qweasd" > (Ctrl+Z) > "qweas" > (Ctrl+Z) > "qwea" > ...
Actual: the "rty" appears like this: "qweasdf" > (Ctrl+Z) > "qwerasdf" > (Ctrl+Z) > "qwertasdf" > (Ctrl+Z) > "qwertyasdf"

Also reproducible with clicking the "undo button" in toolbar, and with clicking "edit > undo"
Comment 3 Björn Michaelsen 2011-12-23 13:25:24 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 Scott M. Sanders 2012-02-08 12:08:37 UTC
I can reproduce this issue in LibO 3.5.0 RC3 on editing a Calc function.
Comment 5 Viktor Mileikovskyi 2012-04-26 08:42:14 UTC
I reproduced this bug in versions from 3.4.3 to 3.5.2 on Ubuntu 11.04 x86_64. After editing and undoing in large modules it's code converts to garbage. So, I change from Windows(All) to All.

Please help me because I can not use Undo feature and must remember-retype a code manually.
Comment 6 Ivan Timofeev (retired) 2012-06-28 03:40:59 UTC

*** This bug has been marked as a duplicate of bug 37405 ***