Bug Hunting Session
Bug 40215 - SPELL: UI broken, impossible to add new words
Summary: SPELL: UI broken, impossible to add new words
Status: RESOLVED DUPLICATE of bug 36678
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-18 23:04 UTC by Rainer Bielefeld Retired
Modified: 2011-09-05 05:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot User-defined_dictionaries1 (17.11 KB, image/png)
2011-09-05 05:01 UTC, rpr
Details
screenshot Add_new_word_to_user_defined_dictionary1 (13.57 KB, image/png)
2011-09-05 05:02 UTC, rpr
Details
screenshot User-defined_dictionaries2 (17.33 KB, image/png)
2011-09-05 05:03 UTC, rpr
Details
screenshot Add_new_word_to_user_defined_dictionary2 (13.15 KB, image/png)
2011-09-05 05:03 UTC, rpr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-08-18 23:04:43 UTC
Steps to reproduce:
0. Open document with some text, at least 1 word with correct spell, 
   but recognized as misspelled
1. <f7> for spell check
2. when you reach correct word recognized as misspelled, Press button <add> in
   spell check dialog
   Expected: selection "standard.dic" or similar appears so that you can select
             where you want to add the word
   Actual: Nothing

Observed with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]" 

Works for me with a 3.4.1 Daily build
Comment 1 Rainer Bielefeld Retired 2011-08-18 23:05:58 UTC
May be some workaround for "Bug 37195 - Dictionary access lost after LibO upgrade" broke this function?
Comment 2 vitriol 2011-08-18 23:17:36 UTC
Not reproducible on my system, it works like expected. LibO 3.4.2 Italian under Win7 64bit HP Italian.
Comment 3 vitriol 2011-08-18 23:21:15 UTC
PS
I had already applied the workaround for Bug 37195 some time ago, after upgrade from 3.4.1 to 4.4.2
Comment 4 vitriol 2011-08-18 23:22:45 UTC
(In reply to comment #3)

> from 3.4.1 to 4.4.2

ehm... from 3.4.1 to 3.4.2
Comment 5 Rainer Bielefeld Retired 2011-08-18 23:26:42 UTC
"standard.dic" does exist in my 
C:\Users\user\AppData\Roaming\LibreOffice\3\user\wordbook\
Comment 6 Rainer Bielefeld Retired 2011-08-18 23:49:44 UTC
@vitriol:
I believe you talk about workaround replacing?

I know Comment 31 from Bug 37195 - Dictionary access lost after LibO upgrade

My registrymodifications.xcu shows
oor:name="ActiveDictionaries" oor:op="fuse"><value>
<it>standard.dic</it><it>soffice.dic</it><it>technical.dic</it><it>IgnoreAllList</it>
</value></prop></item>
<item oor:path="/org.openoffice.Office.Linguistic/General/DictionaryList">
<prop oor:name="IsUseDictionaryList" oor:op="fuse">
<value>true</value></prop></item>
<item oor:path="/org.openoffice.Office.Linguistic/General">
<prop oor:name="IsIgnoreControlCharacters"

I do not have any unchecked dict. in Writing aids - Available Language modules.
Comment 7 Rainer Bielefeld Retired 2011-08-18 23:51:53 UTC
But deleting my user profile heals that problem
Comment 8 vitriol 2011-08-19 00:00:01 UTC
I just replaced the file configmgr.ini. No other manual actions performed to the user profile.
Comment 9 Rainer Bielefeld Retired 2011-08-19 00:07:49 UTC
Using registrymodifications.xcu from newly created user profile after having switched back to my normal user profile does not heal the problem, must be something else.

@vitriol: (In reply to comment #8)
for what problem? This one or Bug 37195 - Dictionary access lost after LibO upgrade? I observed the problem after having replaced configmgr.ini for 3.4.3 in the user profile by the one from the program folder-
Comment 10 vitriol 2011-08-19 00:16:06 UTC
@Rainer Bielefeld
I replaced configmgr.ini as a workaround of Bug 37195. Despite this change, I don't see the problem exposed in this bug on my 3.4.2 installation.
I haven't checked version 3.4.3 RC1.
Comment 11 Rainer Bielefeld Retired 2011-08-19 00:17:36 UTC
That's the problem in this spellcheck thingy - these various problems all appear randomly and are difficult to confirm.
Comment 12 Rainer Bielefeld Retired 2011-08-19 00:56:53 UTC
After some unsuccessful action I now found a way to heal my problem. When I reached a word I wanted to add, I first clicked <Options>, unchecked "standard Deutsch", closed dialog, reopened, checked again. Now I am able to use <add> Word.

But the repair only works for the current spellcheck session. After exit from spellcheck and new <f7> I have to do the same repair

I'm afraid no one else will run through the same proceeding to get this problem, I created a reminder for 2011-September-19 to close this bug if no one has been able to confirm the problem.
Comment 13 manj_k 2011-08-19 02:04:03 UTC
Maybe related to 'Bug 36678 - Missing user-defined dictionaries with a specified language attribute via "Spelling and Grammar" <F7>'?

Adding a word via (right-click) context menu is OK?

But 'standard.dic' with 'Language [All]' should work via <F7> nevertheless.

What is the encoding of your unavailable 'standard.dic'
(...\LibreOffice\3\user\wordbook\)

Does it show (opened with a text editor):
OOoUserDict1
lang: <none>
type: positive
---                                      ?

Does a newly created 'standard.dic' ('Language [All]') work for you?
1. Rename 'standard.dic' in the user profile.
2. 'Tools > Options > Language Settings > Writing Aids > 
User-defined dictionaries > New...'
Comment 14 Rainer Bielefeld Retired 2011-08-19 02:27:24 UTC
Yes, that indeed sounds related. I have been wondering for a long time why I only see "standard.dic' where I can add. But My LibO time resource for today is used up, I will check that later.
Comment 15 Jeffrey 2011-08-20 07:28:05 UTC
Not reproducible for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.
Comment 16 rpr 2011-09-05 04:59:34 UTC
I've checked this on a fresh install of LibO 3.4.3 on a MS Windows XP
Pro. SP3 and here is the result:

(1) If a user-defined dictionary is set to be used for ALL languages
then it appears on the Add new word list. See the following attachments:
User-defined_dictionaries1.png
Add_new_word_to_user_defined_dictionary1.png

(2) If you limit a user-defined dictionary to a specific language then
the dictionary does not appear on the Add new word list even if the
checked word is in that particular language. Next two attached images
(User-defined_dictionaries2.png and
Add_new_word_to_user_defined_dictionary2.png) illustrate that case for
text written in US English.

I'd say this bug is duplicate of bug 36678.

-- rpr.

*** This bug has been marked as a duplicate of bug 36678 ***
Comment 17 rpr 2011-09-05 05:01:46 UTC
Created attachment 50913 [details]
screenshot User-defined_dictionaries1
Comment 18 rpr 2011-09-05 05:02:21 UTC
Created attachment 50914 [details]
screenshot Add_new_word_to_user_defined_dictionary1
Comment 19 rpr 2011-09-05 05:03:07 UTC
Created attachment 50915 [details]
screenshot User-defined_dictionaries2
Comment 20 rpr 2011-09-05 05:03:35 UTC
Created attachment 50916 [details]
screenshot Add_new_word_to_user_defined_dictionary2