Download it now!
Bug 40320 - Pie charts colors messed up when saving opening Excel (.xls) documents
Summary: Pie charts colors messed up when saving opening Excel (.xls) documents
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.6.0 target:3.5.2
Keywords:
: 46120 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-08-23 11:52 UTC by 3b2005
Modified: 2012-03-07 19:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Side by side comparison of original pie charts and the way they show up when the .xls file is reopened (42.86 KB, application/pdf)
2011-08-23 11:52 UTC, 3b2005
Details
LO adds the "sub-title" text in the title bar of bar charts when opening from .xls file (112.21 KB, image/png)
2011-08-23 12:18 UTC, 3b2005
Details
file with chart from 3.3.0, saved as .xls (7.50 KB, application/vnd.ms-excel)
2012-02-06 01:12 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 3b2005 2011-08-23 11:52:47 UTC
Created attachment 50504 [details]
Side by side comparison of original pie charts and the way they show up when the .xls file is reopened

I have made some charts in a spreadsheet in LO 3.3.2, and saved the file in .xls format. After I installed LO 3.4.2, the pie charts load with the same colour in all the regions. After I change the colours again and save the file, when I open the saved file the colours become messed up again (only one colour for all regions). The same thing happens if I try to insert the file as an OLE object in Writer. I'm attaching a .pdf file comparing the way the charts looked just before I closed the spreadsheet and afterwards.
Comment 1 3b2005 2011-08-23 12:03:31 UTC
Forgot to mention: I'm using LO 3.4.2, in Ubuntu 10.04 32-bit.
Comment 2 3b2005 2011-08-23 12:16:59 UTC
When I opened the .xls file, LO also removed the Data Labels from all charts, and it added the "sub-title" text to the title (it is displayed on a second line, but still in the same text box). I'll add another attachement.
Comment 3 3b2005 2011-08-23 12:18:17 UTC
Created attachment 50505 [details]
LO adds the "sub-title" text in the title bar of bar charts when opening from .xls file
Comment 4 Jeffrey 2011-08-23 18:27:36 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

Created Pie chart in calc, color display was red and blue. Saved as .xls format. When reopened, both regions were blue.
Comment 5 sasha.libreoffice 2012-02-02 01:41:53 UTC
reproduced in LibO 3.5.0 beta and 3.6.0 master on Fedora 64 bit
but not reproduced in LibO 3.3.4, therefore regression
Comment 6 sasha.libreoffice 2012-02-02 01:44:42 UTC
@ Kohei
Please, see on it. It is regression since 3.3.4
Comment 7 Cor Nouws 2012-02-06 01:12:40 UTC
Created attachment 56644 [details]
file with chart from 3.3.0, saved as .xls

I can confirm that all 3.3.x versions open this correct
and that from 3.4.0 the problem exists
Comment 8 Alexander Kubashin 2012-02-16 01:49:45 UTC
I'm have same problem with LO 3.5.0 release in Windows XP.
Comment 9 Kohei Yoshida 2012-02-22 07:41:55 UTC
I'll take a look.
Comment 10 Not Assigned 2012-02-24 11:50:11 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67f37b1de7e64e3225844cfe38b9b1adace3fd85

fdo#40320: Correctly import data point formats in data series.
Comment 11 Not Assigned 2012-02-24 12:46:02 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89e836c64a885b676673af33bf98e5ef97869daf

fdo#40320: Insert only a placeholder since the caller relies on this behavior.
Comment 12 sasha.libreoffice 2012-02-24 22:15:56 UTC
Thanks
Comment 13 Not Assigned 2012-02-27 18:01:35 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f2cf45c6f423c3ad1e12307e8f02a5014a3b913&g=libreoffice-3-5

fdo#40320: Correctly import data point formats in data series.


It will be available in LibreOffice 3.5.2.
Comment 14 Not Assigned 2012-02-27 18:02:01 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c78ff5de2ac1e10e68876ef586c0f2d9d5d626a&g=libreoffice-3-5

fdo#40320: Insert only a placeholder since the caller relies on this behavior.


It will be available in LibreOffice 3.5.2.
Comment 15 Kohei Yoshida 2012-03-06 12:36:45 UTC
Marking this fixed.
Comment 16 Kohei Yoshida 2012-03-07 19:58:47 UTC
*** Bug 46120 has been marked as a duplicate of this bug. ***