Bug 40362 - VIEWING: HANG in presentation mode showing animated GIFs
Summary: VIEWING: HANG in presentation mode showing animated GIFs
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-24 16:46 UTC by Mr. Aljoriz Dublin
Modified: 2012-09-17 06:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Death of LibreOffice by animated gif! (2.71 MB, application/vnd.oasis.opendocument.presentation)
2011-11-15 06:40 UTC, Edward d'Auvergne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mr. Aljoriz Dublin 2011-08-24 16:46:25 UTC
Lib0 3.4.2 impress hangs while using an animated GIF on full screen presentation mode (F5).  This has been reproduced in x86 and x86-64 Linux Debian.

Workaround:
Install Lib0 3.3.2rc2, it can handle animated GIF.  I can only wonder what went wrong with 3.4.2
Comment 1 Jeffrey 2011-08-25 18:51:53 UTC
Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux. Animated GIF works fine in view presentation mode.
Comment 2 Rainer Bielefeld Retired 2011-08-27 02:29:28 UTC
Related to "Bug 33130 - Presentation locks window manager UI while playing animated gif"? But that one was for LibO 3.3.0

@Mr. Aljoriz Dublin:
Please attach a test kit (Presentation with Gif)!
Comment 3 Mr. Aljoriz Dublin 2011-08-27 07:51:13 UTC
http://www.fileserve.com/file/K6Xg7wu/sample.odp the file is 6mb 3pages of gif slides.. I tweaked with the memory in Libre so that I would use 256mb and 50mb memory per object and it now works.
Comment 4 Rainer Bielefeld Retired 2011-08-27 08:48:11 UTC
Mr. Aljoriz Dublin
Please use "Add an attachment" to attach the document here.

If it's too big please use <http://wiki.documentfoundation.org/QA/Bugzilla-Attachments>
Comment 5 Mr. Aljoriz Dublin 2011-08-27 17:43:10 UTC
Sorry! the file is actually 6MB not mb, yes its big and the bugs.freedesktop can only handle 300kb or something I think.

It would greatly help me if you can provide a step by step on how to upload bugkits to the wiki.  sorry for being a newbie
Comment 6 Rainer Bielefeld Retired 2011-08-28 03:32:21 UTC
fileserve.com seems to be very interested to animate people to buy the premium service :-(
But I was able to download the document, everything worked fine for me, but what the heck is the "fullscreen mode"? I started the presentation with <f5> and alternatively with <f9>, and always everything works fine.

Linux (distri) specific? Only a glitch with 3.4.2? 

@Mr. Aljoriz Dublin:
The problem disappears when you delete slides 2,3 - or why do you use this gigantic sample document?

What's with a simple presentation created from the scratch with an animated gif like <http://de.wikipedia.org/wiki/Datei:KURBEL-4_Vakuum-Motor_Funktion.gif>?

If you want to attach another sample, please also attach the separate .gif (zipped together with the presentation.
Comment 7 Mr. Aljoriz Dublin 2011-08-28 04:44:57 UTC
thank you will refrain from using too much animated gifs then.
Comment 8 Edward d'Auvergne 2011-10-23 12:42:03 UTC
I can confirm this bug, and it's big and nasty!  Looks like a massive memory leak.  I opened up a number of old .odp files with some big animated gifs.  I have presented these on earlier versions of open office with no problems.  But Libreoffice 3.3.3.1 (from Mageia) and 3.4.3 (rpms from the Libreoffice download page) both die spectacularly opening these things.  The program doesn't hang, but it's response time is in the order of ~5 min per mouse click.  And the system memory goes away very quickly, and the CPU is burning.

The system is x86-64 and, importantly, GNU/Linux.  Due to the whole desktop becoming incredibly slow, I am unable to do any probing to see where the problem lies exactly.  I hope this is recognised as a bug, and fixed very soon.  It's difficult to kill the program and get the system to be responsive again without switching to a virtual terminal.  This should have a very high priority!
Comment 9 Mr. Aljoriz Dublin 2011-10-23 16:55:55 UTC
bug still present in 3.4.3 debian libreoffice.  

why animated gif? well, if you do presentations as a part of working its very important.  I'd be honest and say that I was a slightly offended when someone asked why I bothered with animated gifs in the first place; thank you Edward for confirming it for me.
Comment 10 Edward d'Auvergne 2011-11-15 06:36:43 UTC
This is still an incredibly critical bug for me!  I cannot open and use many of my old presentations which have embedded animated gifs.  The only way I can have my system responsive again is if I kill the program.  I cannot not resolve the problem of accessing old presentations for slide recycling - a very valid usage.

I am using GNU/Linux x86-64 with LibreOffice 3.3.3.  It is also a problem if I use the newest 3.4.3 release.  I would suggest changing the importance to 'highest'.  The system becomes unresponsive as all the RAM is chewed up, and then massive swapping occurs.  It looks like LibreOffice is maybe trying to pre-load these things as uncompressed bitmaps into the RAM when the file is first opened?!
Comment 11 Edward d'Auvergne 2011-11-15 06:40:32 UTC
Created attachment 53573 [details]
Death of LibreOffice by animated gif!

Here is a test case ODP file with a single animated gif of ~2.8 Mb inserted twice into two slides.  This file is unworkable on my system, it took a long time to create, save, and close the program (over 20 min).
Comment 12 Edward d'Auvergne 2011-11-15 11:24:33 UTC
The fix to bug #32861 (https://bugs.freedesktop.org/show_bug.cgi?id=32861) present in version 3.4.4 appears to slightly improve the situation, though my presentations are still not in a usable state.  I think that bug is a duplicate of this one, but that the fix is only partial.  The response time is still can be measured in the >5 minute range.  If the animated gif is not in the first few slides (on the left side), the GUI is responsive until you slide down to where the animations are.

Closure of the left hand side slide pane seems to fix the problem.  For the slide previews, maybe there is an issue with how the first frame of the animated gif is fetched from memory?  Nevertheless, the animations are not smooth as they used to be in early OpenOffice versions.  And closing the presentation while on an animation slide takes forever.  The attached presentation (https://bugs.freedesktop.org/attachment.cgi?id=53573) still demonstrates the problems in version 3.4.4.
Comment 13 Jean-Baptiste Faure 2011-11-15 21:56:17 UTC
No crash for me in slideshow mode with LibO 3.4.4 under Ubuntu 10.04 x86_64, even when starting from the normal view with the left pane showing the slides previews. 
I tested with the master too (build this night, LibreOffice 3.5.0 Build ID: 87be97a-5d03837-adcf6d5-c4bb9bd-ce71330). Comparing both version, it's clear that the slideshow is smoother in the master. In fact in LibO 3.4.4 there is an high memory consumption, bigger than with the master.

You should try a daily build, if the behavior is better, the we can guess the problem is really in LibO 3.4. If not there is perhaps something in your machine configuration.

Best regards. JBF
Comment 14 Carlo Strata 2011-11-16 01:14:59 UTC
Hi Everyone,

*no* crash (all was right) in opening and in presenting with:

LibreOffice:
LibreOffice 3.4.4 
OOO340m1 (Build:402)
Vanilla one RC2/final
linux x86-64

OS:
OpenSuSE 11.2 Updated (within December 2011 I update to the today been born 12.1 one)
x86-64 architecture
kernel 2.6.38.6-5-default
Gnome 2.30.2
KDE 4.6.3 (4.6.3) "release 4"

Graphics:
GeForce 9500M GS - 512 Mbyte dedicated VRAM
nVidia, linux, x86-64, proprietary driver, version 290.06 (very stable beta) from here
ftp://download.nvidia.com/XFree86/Linux-x86_64/
(I think that with OpenSuSE 12.1 I will use nouveau driver from here
http://nouveau.freedesktop.org/ or distro one)

HTH,

Carlo
Comment 15 irmhild.rogalla 2011-11-16 03:32:03 UTC
hi,

*no* crash, too with:

LibreOffice 3.4.3 
OOO340m1 (Build:302)

Debian 
Version 6.0-updates (squeeze)
Kernel Linux 3.0.0.1-amd64
GNOME 3.0.2

x86-64bit system

Nvidia Driver Version 275.28
GeForce 8600 GT

hth!
Comment 16 Friedrich Strohmaier 2011-11-17 15:43:16 UTC
No crash here with attached file. Original posters file no longer available.

LibreOffice 3.4  340m1(Build:402)

(outdated) Ubuntu 7.10

Friedrich
Comment 17 Carl Michael Skog 2011-12-07 23:38:25 UTC
No crash on a recent build on an up-to-date of master, but impress takes hefty amount of CPU and the UI is largely unresponsive, but the application does not hang.

System(uname -a):
Linux 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Comment 18 Jean-Baptiste Faure 2011-12-26 12:44:38 UTC
@Mr. Aljoriz Dublin and Edward d'Auvergne: Please could you try current beta version of LibreOffice 3.5.0 (http://www.libreoffice.org/download/pre-releases/)?
Bugdoc provided by Edward works without problem for several testers.

Best regards. JBF
Comment 19 Mr. Aljoriz Dublin 2011-12-26 16:46:36 UTC
will do

On Mon, Dec 26, 2011 at 8:44 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=40362
>
> --- Comment #18 from Jean-Baptiste Faure <jbf.faure@orange.fr> 2011-12-26
> 12:44:38 UTC ---
> @Mr. Aljoriz Dublin and Edward d'Auvergne: Please could you try current
> beta
> version of LibreOffice 3.5.0
> (http://www.libreoffice.org/download/pre-releases/)?
> Bugdoc provided by Edward works without problem for several testers.
>
> Best regards. JBF
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 20 Mr. Aljoriz Dublin 2011-12-28 17:22:08 UTC
Tried LibreOffice 3.5.0 beta2.  Used 2animated gifs there is a slight improvement but playing the slide will make the pc run very slowly or the program will not respond. 

Issue is still not resolved, at least for me.

SYSTEM:
Mint Debian 32bit 2gig ram
LibreOffice system memory settings
     Graphic Cache:      256MB
     Memory per object:  20
Comment 21 sasha.libreoffice 2012-03-22 07:38:53 UTC
In 3.5.1 on Fedora 64 bit attachment not hangs.
Consumes much resources, but not hangs.
Please, verify if this bug still reproducible or may close
Comment 22 Florian Reisinger 2012-08-14 14:02:25 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 23 Florian Reisinger 2012-08-14 14:03:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 24 Florian Reisinger 2012-08-14 14:07:57 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 25 Florian Reisinger 2012-08-14 14:10:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 26 sasha.libreoffice 2012-09-17 05:09:14 UTC
currently not hangs and not crashes. Changing to WFM
Comment 27 Jean-Baptiste Faure 2012-09-17 06:49:34 UTC
(In reply to comment #26)
> currently not hangs and not crashes. Changing to WFM

What do you by "currently" ?

Best regards. JBF
Comment 28 Jean-Baptiste Faure 2012-09-17 06:50:50 UTC
(In reply to comment #27)
> (In reply to comment #26)
> > currently not hangs and not crashes. Changing to WFM
> 
> What do you by "currently" ?
> 
> Best regards. JBF

Sorry, sent too quickly. My question was:
What do you mean by "currently" ?

Best regards. JBF
Comment 29 sasha.libreoffice 2012-09-17 06:55:11 UTC
3.5.5 and 3.6.1 on Fedora 64 bit