Bug 40483 - Connector Lines have wrong geometry after .pptx Import
Summary: Connector Lines have wrong geometry after .pptx Import
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-30 02:49 UTC by Christian
Modified: 2013-10-01 11:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PowerPoint Slide with Connectors (75.84 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-08-30 02:49 UTC, Christian
Details
Screenshot of original PowerPoint geometries (197.57 KB, image/png)
2011-08-30 02:52 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2011-08-30 02:49:37 UTC
Created attachment 50678 [details]
PowerPoint Slide with Connectors

FILEOPEN

Importing MS PowerPoint Presentation (.pptx MS-O-2007) fails.
Connector Lines have wrong geometry after Import/Opening.
Comment 1 Christian 2011-08-30 02:52:21 UTC
Created attachment 50679 [details]
Screenshot of original PowerPoint geometries

This screenshot can be used to compare how the connectors are supposed to be drawn.
Comment 2 Björn Michaelsen 2011-12-23 12:40:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-03-29 01:34:36 UTC
reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit
dotted lines becomes solid on slide
Comment 4 A (Andy) 2013-04-24 21:42:05 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 5 Samuel Mehrbrodt (CIB) 2013-04-25 15:16:55 UTC
What do you mean with "Wrong geometry"?
When I open it in version 4.0.2, it gets imported correctly.
Comment 6 A (Andy) 2013-04-25 18:41:10 UTC
@Samuel: dotted lines became solid lines
Comment 7 Zeki Bildirici 2013-09-30 09:01:43 UTC
(In reply to comment #6)
> @Samuel: dotted lines became solid lines

In LibreOffice 4.1.1.2 imported in a very accurate geometry. Animation is good too.

Dotted lines are not solid lines but have higher density of dots, you may see dotted if you zoom a litte bit. In full screen they can be seen, also it wont be a problem in a presentition panels/screens.

Seems to be fixed.

Best regards,
Zeki
Comment 8 sasha.libreoffice 2013-10-01 11:31:17 UTC
On Ubuntu in 4.0.2 line is dotted in editing and show mode
on Fedora in 4.0 and 4.1 line is solid and in show mode program crashes

Status of bug should be WorksForMe if we do not know which patch fixed it