Bug Hunting Session
Bug 40493 - SPELL checker does not work with soffice.exe in non-default folder
Summary: SPELL checker does not work with soffice.exe in non-default folder
Status: RESOLVED DUPLICATE of bug 37195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-30 08:04 UTC by Alex Carnes
Modified: 2011-12-22 05:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Carnes 2011-08-30 08:04:55 UTC
Because I'm running out of space on my boot partition, I decided to install LibreOffice to my D drive in D:\Program Files\LibreOffice 3.4\. However, the 'check spelling as you type' feature doesn't work (and didn't with 3.4.2 either). If I perform a default install to drive C, it works fine.

LibreOffice 3.4.3 RC2, XP x64 SP2
Comment 1 Rainer Bielefeld Retired 2011-08-31 05:16:17 UTC
That looks like a DUP of "Bug 37195 - Dictionary access lost after LibO upgrade", although "If I perform a default install to drive C, it works fine" makes me wonder. 

Seems to be an installation issue.

@Alex
Really only a WRITER problem or also visible in CALC?
What do you see in menu 'Tools -> Options -> Language settings -> Writing aids - Language modules'?
If nothing, does the "'configmgr.ini' workaround" help?

Please use <http://wiki.documentfoundation.org/BugReport#Reporting_a_bug_in_4_Steps> for bug reports!
Comment 2 Alex Carnes 2011-09-01 00:57:03 UTC
OK, I just uninstalled it from my c drive and repeated the custom install to drive D. In 'Tools -> Options -> Language settings -> Writing aids
- Available language modules' there is nothing. So it's probably related to Bug 37195, although as I said before, when I upgrade using the default install, the spell checker works. (Obviously the same problem applies to the other apps not just Writer.)

I tried the workaround, i.e. Copy 'configmgr.ini' from the program directory (2.), and paste the file to the user profile directory, but it made no difference.
Comment 3 Caolán McNamara 2011-09-01 07:21:48 UTC
yeah, it could be a duplicate alright. In the sense that the config is "stuck" pointing at c:\path\to\dictionaries. To test that you could install into D:\, blow away the entire AppData/LibreOffice directory, and then start LibreOffice and see if it works then.
Comment 4 Alex Carnes 2011-09-01 07:46:47 UTC
Done!

Blitzed the LibreOffice directories and re-installed to drive D and it worked. I'm rather stupid not to have thought of that myself, although I suppose the problem is still worth solving because all user prefs are lost.

Thanks!

Alex
Comment 5 Caolán McNamara 2011-09-01 07:59:39 UTC
yeah, I reckon its a dupe. "stuck" prereg configuration due to an
un-overwritable common.rdb

*** This bug has been marked as a duplicate of bug 37195 ***
Comment 6 Björn Michaelsen 2011-12-22 05:51:52 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.