Download it now!
Bug 40513 - PDF import - Line spacing and colour/Box colour
Summary: PDF import - Line spacing and colour/Box colour
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-08-31 05:36 UTC by paulmmcbride
Modified: 2014-05-20 06:16 UTC (History)
3 users (show)

See Also:
  • 75667
Crash report or crash signature:


Attachments
sample PDF showing the Draw PDF open problems (99.91 KB, application/pdf)
2011-08-31 05:36 UTC, paulmmcbride
Details
Underline test (8.37 KB, application/pdf)
2014-03-02 12:12 UTC, vvort
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paulmmcbride 2011-08-31 05:36:58 UTC
Created attachment 50754 [details]
sample PDF showing the Draw PDF open problems

If you "open" the attached test file with Adobe Reader and compare how it is opened with LibreOffice Draw (Version 3.4.2: Build 203) - you will notice the following differences (mistakes) with Draw:

1)  The line colour under "Police Check" should be black but is red
2)  The line spacing under "Police Check" is wrong - and overwrites the text
3)  The box colour is different for "An Association" compared to "Independant" - they should be the same (same thing for boxes further down).

Please update the "PDF import/Open".

Thanks...
Comment 1 Björn Michaelsen 2011-12-23 12:41:35 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:04:45 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:05:33 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:09:59 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:11:58 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Dennis Roczek 2013-10-15 13:51:47 UTC
This bug is still valid although nobody has ever update this ticket.
Comment 7 Dennis Roczek 2013-10-15 13:52:28 UTC
BTW: just tested with 4.1.1.2 under Win7 64bit
Comment 8 tommy27 2013-10-17 21:39:44 UTC
bug confirmed in 4.1.2.3 under Win7 64bit as well.
I tested some earlier versions and I can say it worked at least in 3.3.4.

hence REGRESSION
Comment 9 vvort 2014-02-22 07:49:13 UTC
As I can see, problems #1 and #3 are solved in master branch.
Comment 10 vvort 2014-03-02 11:05:39 UTC
#2 is hackfixed here:
https://gerrit.libreoffice.org/8416

This bug is related to poppler's Bug 75667
When Bug 75667 will be fixed, this hackfix will need to be reverted.
Comment 11 vvort 2014-03-02 12:12:10 UTC
Created attachment 94962 [details]
Underline test

Add new test file for underline problems
Comment 12 Commit Notification 2014-03-03 15:22:19 UTC
Vort committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7963d2b0f6fe006c215607eda1c51acf1d7273b5

fdo#40513 PDF Import: Hack: Replace incorrect values of font's ascent property



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2014-03-04 09:26:43 UTC
caolanm->Vort: should we close this now, i.e. everything works in master ?
Comment 14 vvort 2014-03-04 10:08:03 UTC
(In reply to comment #13)
> caolanm->Vort: should we close this now, i.e. everything works in master ?

Yes, thanks.
Comment 15 vvort 2014-05-20 06:16:03 UTC
More correct fix for problem #2 is available here: Bug 78689