Bug Hunting Session
Bug 40538 - FILEOPEN particular .doc (MSO97) shows arrow heads of graphic lines too big
Summary: FILEOPEN particular .doc (MSO97) shows arrow heads of graphic lines too big
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.1:OSX10.9 Confirmed:4...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-01 01:57 UTC by user6
Modified: 2014-09-29 11:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Input file how it is in Word 2003 (37.63 KB, image/png)
2011-09-01 01:57 UTC, user6
Details
input file (20.50 KB, application/msword)
2011-09-01 01:58 UTC, user6
Details
How it is displayed in LibO 3.4.3 Win XP i386 (34.49 KB, image/png)
2011-09-01 02:01 UTC, user6
Details
opened test doc in LibO 3.4.3 on OSX 10.6.8, EN US (70.03 KB, image/png)
2011-09-02 12:21 UTC, digital ant
Details
Still reproduced in LO 3.5.4.2 Win7 (84.45 KB, image/png)
2012-06-07 09:39 UTC, user6
Details
4.3.1.2 screenshot (5.10 KB, image/png)
2014-09-26 21:20 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description user6 2011-09-01 01:57:54 UTC
Created attachment 50793 [details]
Input file how it is in Word 2003

When you import some diagram from DOC (word 2003) in LO you can see enormous rows.
See attached picture how it is in Word and result in LO.
Comment 1 user6 2011-09-01 01:58:50 UTC
Created attachment 50794 [details]
input file
Comment 2 user6 2011-09-01 02:01:49 UTC
Created attachment 50795 [details]
How it is displayed in LibO 3.4.3 Win XP i386
Comment 3 digital ant 2011-09-02 12:21:13 UTC
Created attachment 50849 [details]
opened test doc in LibO 3.4.3 on OSX 10.6.8, EN US

Opened test doc on my Mac with Lib0 3.4.3, Apple Java 1.6.0_26, EN US - while not exactly the same, it is similar to screen shot from word.
Comment 4 user6 2011-09-02 23:20:15 UTC
(In reply to comment #3)
> Created an attachment (id=50849) [details]
> opened test doc in LibO 3.4.3 on OSX 10.6.8, EN US
> 
> Opened test doc on my Mac with Lib0 3.4.3, Apple Java 1.6.0_26, EN US - while
> not exactly the same, it is similar to screen shot from word.

From my point of view looks like you are mistaken. Could you look carefuly on pictures description and content?
I see what LibO shows incorrect size of rows on both platforms WinXP and MacOS X.
Comment 5 Björn Michaelsen 2011-12-23 12:38:37 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 user6 2011-12-26 02:07:06 UTC
I confirm still true for LOdev 3.5.0beta2 
ID сборки: 8589e48-760cc4d-f39cf3d-1b2857e-60db978

When you import some diagram from DOC (word 97/2003 format) in LO you can see enormous rows.(In comparison to when you open it in Word)
Comment 7 sasha.libreoffice 2012-01-17 07:50:13 UTC
reproduced in LibO 3.5.0 beta 1 on Fedora 64 bit 
and in LibO 3.4.3.on Windows XP 32 bit

@Igor version is where bug first time found, and not current version. I change it to 3.3.4
Comment 8 user6 2012-06-07 09:39:46 UTC
Created attachment 62736 [details]
Still reproduced in LO 3.5.4.2 Win7

Bug still reproduced in LO 3.5.4.2 on Win7.
(Also see in Word 2010 same file on the Left)
Comment 9 user6 2012-08-08 19:03:10 UTC
Still reproduced in LO 3.6.0.4 Win7
Comment 10 Valek Filippov 2012-08-09 12:42:08 UTC
Did you mean "arrows" ?
Comment 11 user6 2012-08-09 17:00:36 UTC
(In reply to comment #10)
> Did you mean "arrows" ?

Yes, sorry. Fixed. English is not my native language
Comment 12 user6 2013-02-12 11:00:25 UTC
Still reproduced in LO 4.0.0.3
Comment 13 Rainer Bielefeld Retired 2013-02-12 12:29:41 UTC
Already reproducible with OOo 3.1.1, AOOo 3.4.0, so inherited from OOo
Comment 14 user6 2013-12-21 10:59:56 UTC
In LO 4.1.4.2 the arrows are smaller when before 
but still twice bigger when in Word. (The same page size)
Comment 15 retired 2013-12-21 15:21:43 UTC
Keeps happening with 4.2.0.1 OSX 10.9.
Comment 16 Cédric Bosdonnat 2013-12-23 09:00:37 UTC
remove myself from CC: not hacking writer anymore
Comment 17 tommy27 2014-09-26 21:20:47 UTC
Created attachment 106936 [details]
4.3.1.2 screenshot

arrow heads size looks better in 4.3.0.1

the head shape is however still different from MS Word. see also Bug 82760
Comment 18 user6 2014-09-29 09:28:31 UTC
Fixed in 4.3.2.2.
At last. Thanks
Comment 19 user6 2014-09-29 09:29:20 UTC
Fixed in 4.3.2.2.
Comment 20 tommy27 2014-09-29 11:37:58 UTC
@Igor
nice to hear that.
correct status is WORKSFORME since we don't know the exact committ which fixed it.

so basically the arrow head size issue is RESOLVED
while the arrow head shape issue perists and is described in Bug 82760