Bug Hunting Session
Bug 40592 - attempt to view internet proxy crashes writer/calc/base
Summary: attempt to view internet proxy crashes writer/calc/base
Status: RESOLVED DUPLICATE of bug 47044
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86-64 (AMD64) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-02 19:21 UTC by At2010
Modified: 2012-06-02 00:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description At2010 2011-09-02 19:21:18 UTC
my system:
amd athlon 64 x2 5000+, 4gb ram, nvidia 8400gs + 256mb video
os: windows 7 sp1 home premium 64 bit, sun java jre v6-28

problem occurs in Calc, Writer and Base

Open Tools/Options/Internet. Just clicking on the word Proxy immediately crashes Calc, Writer or Base and orphans the options dialog. The dialog must then be forcibly terminated. Initiates document recovery mode.

This issue occurs every time, is consistent and repeatable. 

Regards,
AT2010
Comment 1 At2010 2011-09-06 10:48:46 UTC
Also occurs on 3.4.3

Discovered crash occurs immediately when selecting ANY Internet option (Proxy, Search or Browser Plug-in)
Comment 2 vitriol 2011-09-06 10:52:11 UTC
Not reproducible for me. You can try with a clean user profile.
Comment 3 At2010 2011-09-06 11:26:17 UTC
I did a clean install of 3.4.3 after uninstalling LibreOffice and removing
product folders from %appdata%/roaming and %programfiles%.

It still crashes when selecting ANY Internet option (proxy, search or
browser plug-in). Are profiles kept elsewhere?


On Tue, Sep 6, 2011 at 1:52 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=40592
>
> --- Comment #2 from vitriol <vitriol_vitriol@katamail.com> 2011-09-06
> 10:52:11 PDT ---
> Not reproducible for me. You can try with a clean user profile.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 4 Björn Michaelsen 2011-12-23 12:35:24 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 At2010 2011-12-24 12:57:51 UTC
The problem persists with 3.4.4 (release) and 3.5.0 beta 2.

If you can provide methods to create more detailed debug logs, please do.

Happy Holidays!
AT2010
Comment 6 Afriza N. Arief 2012-03-22 01:12:24 UTC
I cannot reproduce this with LibreOffice 3.5.1.2 Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66 under Windws 7 32-bit
Comment 7 bfoman (inactive) 2012-05-30 12:59:14 UTC
Quite few similar reports - see Bug 47044 comment 5.
Comment 8 Stefan Knorr (astron) 2012-06-02 00:03:12 UTC
@Bfoman: thanks for finding all those duplicates!

*** This bug has been marked as a duplicate of bug 47044 ***