Download it now!
Bug 40613 - PRINTING: Manual Break ignored in particular documents, same in PDF export
Summary: PRINTING: Manual Break ignored in particular documents, same in PDF export
Status: RESOLVED DUPLICATE of bug 40788
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-03 17:57 UTC by Edward Redondo
Modified: 2014-05-19 12:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with 3 Manual Page Breaks (18.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-09-03 17:57 UTC, Edward Redondo
Details
New Sample Document (9.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-09-04 01:04 UTC, Rainer Bielefeld Retired
Details
PDF Print of Spreadsheet 3 Manual CORRECT Page Breaks (13.59 KB, application/pdf)
2011-09-12 07:15 UTC, Edward Redondo
Details
PDF Print from LibreOffice showing WRONG page breaks (13.98 KB, application/pdf)
2011-12-22 07:55 UTC, Edward Redondo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Redondo 2011-09-03 17:57:37 UTC
Created attachment 50883 [details]
Spreadsheet with 3 Manual Page Breaks

This problem is whit spreadsheets that have Manual Page Breaks inserted.

I created a several spreadsheets that have Manual Page Breaks in OpenOffice 3.2 (see attached example).

In Lib 3.4.3:

1)  The pages do NOT print with the Page Breaks *WHERE* I place them. The print is as if there were NO Manual Page Breaks.

2)  Noted that the "Page Break Preview" is also incorrect.
Comment 1 Rainer Bielefeld Retired 2011-09-04 01:02:36 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and reporter's sample.

Steps to reproduce:
1. open sample document
   You will see a manual break between rows 34-35
2. Click print preview icon
   Expected: rows 35 and following (HEX Code - Weapons - ...) shown on
             second page because of page break
   Actual: rows 35 and following (HEX Code - Weapons - ...) shown on first page

Additional observation:
   Wrong menu item text or wrong help text?
   Help:         Manual Break - Column Break / Row Break
   Menu 'Insert' : Page Break - Column Break / Row Break

"Ignores manual break in preview" also visible with 
Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  3b32204-7f92fce-2ba0a9f)]", 
LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)], 
OOo 3.4.

Works fine with OOo 3.1.1. Heritage from OOo?

Related OOo issue might be 116837 - Calc Not Printing Manual Page Breaks 

@tecknode@cts.com
There is no chart in the document, so I wonder why you selected "Chart" as component?! May be you can test <http://wiki.documentfoundation.org/BugReport_Details> for submitting bug reports?

Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Please add David Nelson to CC if menu item name will have to be modified in Help
Comment 2 Rainer Bielefeld Retired 2011-09-04 01:04:11 UTC
Created attachment 50884 [details]
New Sample Document

It's not a general problem, in this newly created document manual row breaks work fine.
Comment 3 Edward Redondo 2011-09-06 04:52:48 UTC
Note that "New Sample Document" has no data nor borders.

In the "Spreadsheet with 3 Manual Page Breaks" I supplied has both data and borders (borders through page breaks) and I did use "Insert Row Break."
Comment 4 Rainer Bielefeld Retired 2011-09-12 02:38:42 UTC
Additional investigations in "Bug 40788 - FORMATTING - Calc ignores manual breaks when "fit to number of pages" is chosen" show that printer settings are the reason and that the current behavior is intended. Please see Bug 40788 for details!

@tecknode@cts.com
Thank you for your attention!

*** This bug has been marked as a duplicate of bug 40788 ***
Comment 5 Edward Redondo 2011-09-12 05:25:37 UTC
@#$%@ This is NOT resolved.

The "Spreadsheet with 3 Manual Page Breaks" PRINTS CORRECTLY using OpenOffice 3.2 using Sheet settings = 1 "Width in pages" by 5 "Height in pages."



It does NOT print correctly using LibreOffice 3.3.4 (nor OpenOffice 3.3), ON the *same* printer, using Sheet settings = 1 "Width in pages" by 5 "Height in pages."

The page breaks are NOT WHERE I PUT THEM in 3.3 versions of either suite.

Also, who keeps changing the LibreOffice version I reported originally?  My original bug report was on a test using v3.3.4 release.
Comment 6 Rainer Bielefeld Retired 2011-09-12 06:07:17 UTC
@tecknode@cts.com
I modified the version because the PDF export result with 3.4.3 and 3.3.3 looks identical for me (<http://wiki.documentfoundation.org/BugReport_Details#Version>).

May I ask you to cool down, wait until tomorrow and then to read hints on <http://wiki.documentfoundation.org/BugReport> 
and <https://bugs.freedesktop.org/page.cgi?id=bug-writing.html> "Principles" carefully?

Then please:
- Write a meaningful Summary
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary, because
  you can not know what others will see with your sample, you also might want 
  to create mockups concerning your expectations?
  -- what exactly is unexpected
  -- and, most important, why do you believe it's unexpected 
     (cite Help or Documentation! That some behavior (might have been caused 
     by a bug in old version ...?) meets with your needs and / or 
     expectations is not enough to call it "correct".)

You also can get help from user mailing lists.
Comment 7 Edward Redondo 2011-09-12 07:15:48 UTC
Created attachment 51073 [details]
PDF Print of Spreadsheet 3 Manual CORRECT Page Breaks

SORRY - Did a PDF print and LibreOffice 3.3.4 did put the breaks where I had them.

I don't know why I thought it did not.
Comment 8 Björn Michaelsen 2011-12-22 05:51:41 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 9 Edward Redondo 2011-12-22 07:55:55 UTC
Created attachment 54704 [details]
PDF Print from LibreOffice showing WRONG page breaks

This is the EXACT same spreadsheet already attached, but printed using LO and  shows that Manual Row breaks do print incorrectly.
Comment 10 Edward Redondo 2011-12-22 08:01:01 UTC
Note that I've attached the PDF print showing how LO prints Manual Row page breaks in the spreadsheet.

Sorry I forgot to do this before.
Comment 11 Edward Redondo 2012-03-06 06:51:32 UTC
The Calc spreadsheet include was made with OpenOffice 3.2 with 3 Manual Row-Breaks and DOES print correctly in OpenOffice 3.2, but does NOT print correctly in LibreOffice (nor OpenOffice 3.3). There should NOT be a difference on how Manual Row-Breaks are handled.

Users should NOT have to modify Calc spreadsheets between versions of LibreOffice nor OpenOffice. Prints of spreadsheets with Manual Row-Breaks SHOULD print correctly using Page Format, Width in pages x, Height in pages x.

The incorrect behavior of Manual Row-Breaks in OO 3.3+ ALSO appears in
LibreOffice.

According to a Newsgroup post there is a new RC release of LibreOffice 3.5.?

PLEASE, can testers test the "Spreadsheet that does NOT print Manual Breaks in
3.3"bug-report, and check print results against "PDF Print - Spreadsheet with 3
Manual Row breaks CORRECTLY Printed" above.

I am trying to assess IF the bug got corrected or NOT.
Comment 12 Karl Behler 2014-05-19 12:36:07 UTC
This is a duplicate of bug 40788 which is solved since recent. (April 2014)

Unfortunately after release 3.2 (last version allowing manual breaks) Calc behavior was changed to not allow manual breaks when automatic scaling to a particular number of pages was configured in Format > Page > Sheet > Scale .

This has been fixed at least with release 4.2.4.2 again. But requires following additional action by the user:
To enable manual breaks in spreadsheets please go to Tools > options > LibreOffice Calc > Print and tick the behavior "Always apply manual breaks" as default.

*** This bug has been marked as a duplicate of bug 40788 ***