Download it now!
Bug 40694 - Error in message warning that the column limit was exceeded for MS-Excel format
Summary: Error in message warning that the column limit was exceeded for MS-Excel format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium minor
Assignee: Ayantha Randika
URL:
Whiteboard: target:4.3.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
Depends on:
Blocks:
 
Reported: 2011-09-07 11:53 UTC by gamesh.g
Modified: 2016-02-18 16:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
console logs with master sources (3.43 KB, text/plain)
2013-09-14 11:57 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gamesh.g 2011-09-07 11:53:57 UTC
If you save a spreadsheet that has too many columns (I used 500) to Microsoft Excel 97/2000/XP (.xls) format a warning window pops up that says "The document contains more ROWS than supported in the selected format. Additional ROWS were not saved." Emphasis mine. This should say "columns".
Comment 1 Björn Michaelsen 2011-12-23 12:36:40 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 13:58:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:00:07 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:04:46 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:06:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 gamesh.g 2012-08-14 16:44:35 UTC
I just checked with 

LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2)

and this error still persists.

As a side-note, there are four identical comments about closing the bug all sent within ten minutes of each other.

Gil
Comment 7 Michael Meeks 2012-08-15 10:52:17 UTC
thanks for re-testing :-) and yes the quadruple comments was an unfortunate accident.
Comment 8 Michael Meeks 2012-08-15 11:11:30 UTC
So - we have both warnings as strings available; we need to be returning SCWARN_EXPORT_MAXCOL instead of MAXROW for this case to get the right string.

I suspect code like this in sc/ is to blame that flattens any rangeoverflow to a MAXROW warning; prolly we want more semantic richness there.

  if( eRet == eERR_RNGOVRFLW )
        eRet = SCWARN_EXPORT_MAXROW;

a git grep for the SCWARN_EXPORT_MAXROW or RNGOVRFLW will show you the code to hack => EasyHack.
Comment 9 Radu 2012-09-06 20:03:59 UTC
I've checked with build 3.7.0.0.alpha0+ I don't get any warning, but with 3.5.4.2 I can reproduce it systematic.
Comment 10 Leopoldo Saggin 2013-07-31 13:30:18 UTC
I had an .xls file (pure labels and personal data and this is why I can't attach it here), soemthing like an adressbook, not very large (105kb) with about 300 records (297 exactly) in 14 fields. I added the 298th record to the file using LibreOffice 4.1.0.4 running on Windows 7 64bit. Everything apparently was ok. When I tried to reopened it gave me: "Error in message warning that the column limit was exceeded for MS-Excel format" and it showed me only 4-5 records.
So I removed LibO version 4.1.0 and remounted LibO 4.0.4. The "currupted" file did not work also in 4.04, so I restared from the original file 4.0.4, I added the 298th record again and I saved the file. When I reopened it in LibO 4.0.4 was ok.
Topoldo
Comment 11 Julien Nabet 2013-09-14 11:57:01 UTC
Created attachment 85825 [details]
console logs with master sources

On pc Debian x86-64 with master sources updated today, I tried to reproduce the problem.
I created a brand new file with 500 columns then saved it as ods => ok
then I saved it as xls file=> no warnings!!

I attached the console logs with each step I made.
Comment 12 Björn Michaelsen 2013-10-04 18:48:13 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 13 Robinson Tryon (qubit) 2013-10-23 17:26:54 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 14 Ayantha Randika 2014-01-22 07:49:15 UTC
Hi.. I hope to give this a try. Im really new here. Where should I start looking?
Comment 15 Ayantha Randika 2014-01-22 08:12:36 UTC
Hi, Im a beginner to the Libreoffice development and this is my first hack.
I have no idea what files to look at to address this issue. Can anyone
please help me? And is there documents I can refer to?
Thank You


On Wed, Jan 22, 2014 at 1:19 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 14 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c14>
> on bug 40694 <https://bugs.freedesktop.org/show_bug.cgi?id=40694> from
> Ayantha Randika <randika.deultima@gmail.com> *
>
> Hi.. I hope to give this a try. Im really new here. Where should I start
> looking?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
> _______________________________________________
> LibreOffice mailing list
> LibreOffice@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/libreoffice
>
>
Comment 16 Samuel Mehrbrodt (CIB) 2014-01-22 08:32:01 UTC
Ayantha, you can use http://opengrok.libreoffice.org/ for Code Search. Pasting the wrong error message there might be a good start.
Comment 17 Ayantha Randika 2014-01-22 08:51:04 UTC
(In reply to comment #16)
> Ayantha, you can use http://opengrok.libreoffice.org/ for Code Search.
> Pasting the wrong error message there might be a good start.

Thank You very much Samuel!
Comment 18 Ayantha Randika 2014-01-22 19:40:04 UTC
It looks like LibreOffice Version: 4.3.0.0.alpha0+ doesnt give any warning when tring to save a spreadsheet that has too many columns as a (.xls).LibreOffice 3.5.7.2 gives wrong warning as mentioned above. But Version: 4.3.0.0.alpha0+ gives nothing.
Comment 19 Samuel Mehrbrodt (CIB) 2014-01-22 19:55:30 UTC
So I'm closing this bug as per Comment 11 and Comment 18
If it still persists, please reopen.
Comment 20 Ayantha Randika 2014-01-22 20:10:55 UTC
I think I have corrected both errors. Now it warns and gives the correct
warning. I will submit the patch for review as soon as I figure out the
"Sending a Patch to Gerrit" instructions.


On Thu, Jan 23, 2014 at 1:25 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  Samuel M. <s.mehrbrodt@gmail.com> changed bug 40694<https://bugs.freedesktop.org/show_bug.cgi?id=40694>
>  What Removed Added  Status REOPENED RESOLVED  Resolution --- WORKSFORME
>
>  *Comment # 19 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c19>
> on bug 40694 <https://bugs.freedesktop.org/show_bug.cgi?id=40694> from
> Samuel M. <s.mehrbrodt@gmail.com> *
>
> So I'm closing this bug as per Comment 11 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c11> and Comment 18 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c18>
> If it still persists, please reopen.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
> _______________________________________________
> LibreOffice mailing list
> LibreOffice@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/libreoffice
>
>
Comment 21 Ayantha Randika 2014-01-25 18:05:14 UTC
I have created a patch to correct this bug.
https://gerrit.libreoffice.org/#/c/7618/5


On Thu, Jan 23, 2014 at 1:40 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 20 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c20>
> on bug 40694 <https://bugs.freedesktop.org/show_bug.cgi?id=40694> from
> Ayantha Randika <randika.deultima@gmail.com> *
>
> I think I have corrected both errors. Now it warns and gives the correct
> warning. I will submit the patch for review as soon as I figure out the
> "Sending a Patch to Gerrit" instructions.
>
>
> On Thu, Jan 23, 2014 at 1:25 AM, <bugzilla-daemon@freedesktop.org> wrote:
>
> >  Samuel M. <s.mehrbrodt@gmail.com> changed bug 40694 <https://bugs.freedesktop.org/show_bug.cgi?id=40694><https://bugs.freedesktop.org/show_bug.cgi?id=40694>
> >  What Removed Added  Status REOPENED RESOLVED  Resolution --- WORKSFORME
> >>  *Comment # 19 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c19> <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c19>
> > on bug 40694 <https://bugs.freedesktop.org/show_bug.cgi?id=40694> <https://bugs.freedesktop.org/show_bug.cgi?id=40694> from
> > Samuel M. <s.mehrbrodt@gmail.com> *
> >> So I'm closing this bug as per Comment 11 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c11> <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c11> and Comment 18 <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c18> <https://bugs.freedesktop.org/show_bug.cgi?id=40694#c18>
> > If it still persists, please reopen.
> >>  ------------------------------
> > You are receiving this mail because:
> >>    - You are on the CC list for the bug.
>
> >
> >> _______________________________________________
> > LibreOffice mailing list
> > LibreOffice@lists.freedesktop.org
> > http://lists.freedesktop.org/mailman/listinfo/libreoffice
> >
> >
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
> _______________________________________________
> LibreOffice mailing list
> LibreOffice@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/libreoffice
>
>
Comment 22 Commit Notification 2014-01-25 20:17:32 UTC
Ayantha Randika committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28e9efe5b4d6699b33498953e798f76008edaeda

fdo#40694 - Error in message when truncating col/row numbers in calc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Robinson Tryon (qubit) 2015-12-16 00:09:42 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp TopicCleanup)
[NinjaEdit]
Comment 24 Robinson Tryon (qubit) 2016-02-18 16:37:33 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]