Download it now!
Bug 40746 - Macro Fails to Execute
Summary: Macro Fails to Execute
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.0.2 target:4...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-09 13:15 UTC by Joseph Conner
Modified: 2015-01-08 13:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Macro Crash Source Document (432.00 KB, application/vnd.ms-excel)
2011-09-09 13:25 UTC, Joseph Conner
Details
avform20110831.ods (91.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-09-09 13:29 UTC, Joseph Conner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Conner 2011-09-09 13:15:58 UTC
Attached is a file, which opens and functions correctly in OpenOffice.org 3.3.0 but fails to execute the macros in Libre 3.4.2.
Comment 1 Joseph Conner 2011-09-09 13:25:19 UTC
Created attachment 51017 [details]
Macro Crash Source Document

Attached is an Excel source file.  After opening it with LO 3.4.2 and stepping through the numberous macro failures, it will open.  Then by deleting the worksheets that call the offending macros, the remainder works beautifully.  Then save the file as a .ods, close it, and reopen it.  No macro is working again.  The saving corrupted the macros that were working a moment ago.
Comment 2 Joseph Conner 2011-09-09 13:29:50 UTC
Created attachment 51018 [details]
avform20110831.ods

The attached file (avform20110831.ods) was saved from the working LO3.4.2 after opening the Excel. file already uploaded.
Comment 3 Joseph Conner 2011-09-13 13:14:26 UTC
Is anyone looking at this?
Comment 4 Björn Michaelsen 2011-12-23 12:34:12 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Florian Reisinger 2012-08-14 13:58:01 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 13:59:20 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:03:54 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:06:08 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 Commit Notification 2014-12-22 05:25:27 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e551da43da5661396fbc2530a203d4774e29f78

fix OOXML validation error, related fdo#40746

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-12-22 05:25:30 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b241910325456b32c2d3614c2e200305e85a357c

fix another validation error for OOXML, related fdo#40746

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-01-07 14:04:57 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0095c410c5a47aef2fa28b69412067a8aa6a89a1&h=libreoffice-4-4

fix OOXML validation error, related fdo#40746

It will be available in 4.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-01-07 14:14:05 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97b85e69a1585c366907584751c869f45062ec43&h=libreoffice-4-4

fix another validation error for OOXML, related fdo#40746

It will be available in 4.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-01-08 13:28:30 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1eb1d5a643f3526d540abe783edac78c8ded476b&h=libreoffice-4-3

fix OOXML validation error, related fdo#40746

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-01-08 13:30:58 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=62bc15f270614afa37c6615fc34cd79f45026da5&h=libreoffice-4-3

fix another validation error for OOXML, related fdo#40746

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.