Download it now!
Bug 40766 - Writer crashes after being open for a long time
Summary: Writer crashes after being open for a long time
Status: RESOLVED DUPLICATE of bug 37850
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) other
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-10 17:07 UTC by gingaz
Modified: 2011-09-23 11:41 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gingaz 2011-09-10 17:07:23 UTC
Writer crashes after being open for a long time.

Usually is what I do:

1. Keep Writer open for a longer time (1-2 hours or event whole day).

I do only basic stuff during that time: type, insert a several pictures from a file, create a table, create some headers, countless times of save.
2. Then put PC to standby mode.
3. Wake up usually after 1 hour.
4. Activate Writer window and start typing immediately, or
   activate Writer window and scroll from the current position to the very top/bottom of the document. 
Writer it crashes ONLY when you try to use it.

I've noticed that Writer always crashes after this combination. Although I think standby mode is not necessary.

OS: Ubuntu 11.04
LibreO: 3.4.3 final
Hardware: Lenovo x201s (intel i3).

Also, the same problem was in: 
Ubuntu 11.04 + 3.3x;
Ubuntu 10.x + OpenOffice (any version)

Sorry if the bug is already registered. I've looked for it and found only "sleep+freeze" problem.
Comment 1 gingaz 2011-09-10 17:10:38 UTC
If I remember right, this applies to the whole Office package, e.g. if Writer crashes, then all Office modules "go own". 
And if I manage to crash for example Calc, it crashes all other modules too.

Will try that out.
Comment 2 gingaz 2011-09-18 12:08:13 UTC
(In reply to comment #1)
> If I remember right, this applies to the whole Office package, e.g. if Writer
> crashes, then all Office modules "go own". 
> And if I manage to crash for example Calc, it crashes all other modules too.
> 
> Will try that out.

Additional problem - sometimes Writer crashes constantly after long duration of work. On recovery it crashes immediately again. I have to restart the system.
Comment 3 Björn Michaelsen 2011-09-23 11:41:18 UTC
Most likely bug 37850, making a dupe because details to differentiate are missing.

*** This bug has been marked as a duplicate of bug 37859 ***
Comment 4 Björn Michaelsen 2011-09-23 11:41:39 UTC

*** This bug has been marked as a duplicate of bug 37850 ***