Bug Hunting Session
Bug 40902 - FILEOPEN CRASH with trivial lorem ipsum text document
Summary: FILEOPEN CRASH with trivial lorem ipsum text document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-09-15 01:09 UTC by Rainer Bielefeld Retired
Modified: 2011-12-01 08:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (17.32 KB, application/vnd.oasis.opendocument.text)
2011-09-15 01:09 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-09-15 01:09:18 UTC
Created attachment 51229 [details]
Sample Document

Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]" crashes when I try to open attached document (and others) from LibO Start Center File dialog (WIN)
Comment 1 manj_k 2011-09-15 01:41:28 UTC
I have seen this bug with
- master~2011-09-10_23.04.28_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe     12-Sep-2011
- master~2011-09-09_19.24.47_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe     11-Sep-2011
[also crash with FILESAFE]

Not reproducible (any more) with
LibO-dev 3.5.0 
Build ID: 8cc839d-3dca5fd-4525197
[master~2011-09-12_16.09.34_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe     13-Sep-2011 22:24]
Comment 2 manj_k 2011-09-15 10:59:01 UTC
Reproducible (on WinXP 32b) with
LibO-dev 3.5.0 
Build ID: 81607ad-3dca5fd-da627d2
[master~2011-09-13_20.44.55_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe     15-Sep-2011 03:29]


Builds *without* this bug:

- LibO-dev 3.5.0 
Build ID: d3d1481-3f8994a-2ba0a9f
[master~2011-09-06_02.34.59_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe     07-Sep-2011]

- LibO-dev 3.5.0 
Build ID: 8cc839d-3dca5fd-4525197
[master~2011-09-12_16.09.34_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe    
13-Sep-2011 22:24]
Comment 3 Rainer Bielefeld Retired 2011-09-18 07:30:58 UTC
Also [Reproducible] with Parallel installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 052f181-5646d8e-3f8994a-4525197-38a31e0)] (Tinderbox Voreppe 110909)"

@Cédric:
Although my latest test build is dated before the one of original report I think that this bug still exists.
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Alex Thurgood 2011-09-28 08:35:36 UTC
Can not reproduce on :

LibO-dev 3.5.0 
Build ID: 6058133-1b94742-3dca5fd-7252360

with Mac OSX. The extension works without crashing. Windows specific ?


Alex
Comment 5 Roman Eisele 2011-12-01 03:49:42 UTC
Not reproducible with the given sample document
on MacOS X 10.6.8 with
LibO-dev 3.5.0 
Build ID: 549f928-b211287-090bcba-45cf606
built on 2011-12-01,
no langpack applied (default UI).

Bug fixed in between or a Windows-only bug?
Comment 6 manj_k 2011-12-01 07:38:15 UTC
No longer reproducible (UI en-US; on WinXP 32b) with
LibO-dev 3.5.0 · Build ID: 2d0998f-090bcba-45cf606
[master~2011-12-01_08.37.54_libodev35.msi · 01-Dec-2011 13:36
Index of /daily/Win-x86@6-fast/master/current].

Works for me.
Comment 7 Caolán McNamara 2011-12-01 08:12:45 UTC
under Linux valgrind says nothing with todays master
Comment 8 Rainer Bielefeld Retired 2011-12-01 08:51:29 UTC
Yes, still crashes with old version, but WORKS FINE with Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]" Win-x86@9-Voreppe  - 111130)