Download it now!
Bug 40980 - Tamil text will CRASH
Summary: Tamil text will CRASH
Status: RESOLVED DUPLICATE of bug 45355
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-09-17 22:49 UTC by Mayooresan
Modified: 2013-11-24 22:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shots (373.23 KB, application/x-rar-compressed)
2011-09-17 22:49 UTC, Mayooresan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mayooresan 2011-09-17 22:49:54 UTC
Created attachment 51306 [details]
Screen shots

I'm using Windows 7 with libre office. When I type in English it types without any problem.

When I type in Tamil or even when I copy paste Tamil script from internet (ta.wikipedia.org) LibreOffice crashes. When I start the libre office again it invokes the recovery but it has not recovered any of the texts which I typed so far.

I'm not sure this occures for other Indic languages too. I observed same behavior in spreadsheet and other applications too. 

copied following text from window's crash report

Problem signature:
  Problem Event Name:	BEX
  Application Name:	soffice.bin
  Application Version:	3.4.302.500
  Application Timestamp:	4e54357a
  Fault Module Name:	MSVCR90.dll
  Fault Module Version:	9.0.30729.5570
  Fault Module Timestamp:	4d2c14d2
  Exception Offset:	0006ccd5
  Exception Code:	c0000417
  Exception Data:	00000000
  OS Version:	6.1.7600.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	6ed2
  Additional Information 2:	6ed208ae2f5227a80a5c1817a0f17349
  Additional Information 3:	8a24
  Additional Information 4:	8a2435014763a88c09afe0f392c40890
Comment 1 Rainer Bielefeld Retired 2011-09-18 02:12:20 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". Steps to reproduce:

1. Start LibO, open new WRITER document from start Center
2. open Wikipedia <http://en.wikipedia.org/wiki/Aceh_Sultanate>
3. On Wiki page under Languages click "தமிழ்" (third from bottom) what
   will open the Tamil page
4. Mark first text paragraph (not inclucing heading, starting line containing 
   "Aceh Sultanate"
5. <Control+c> for copy
6. change to new WRITER document
7. <Control+v> for paste
   Expected: text appears
   Actual: LibO stops responding, has to be killed by system task manager

Further investigations:
Crash does not happen for any single word, copy/paste only first word of paragraph does not crash.
Longer text and combination Tamil / English crashes
Same problem in CALC

@Sophie:
Any Idea who could proceed this problem?
Comment 2 Rainer Bielefeld Retired 2011-09-18 03:22:51 UTC
Pasted text looks cruelly damaged with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]", but no crash, so regression!
Comment 3 Mayooresan 2011-09-18 03:30:24 UTC
I followed the same steps on Windows 8 dev preview with 3.4.3 and it worked with out any huzzle. 
Something to do with Win 7 only?
Comment 4 Rainer Bielefeld Retired 2011-11-12 00:29:43 UTC
Still [Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) German UI [(Build ID:  6b0de40-0bc4ff4-ca7e6f5-9125509-ce71330)]" (111111) when I copy/paste the paragraph starting with "அச்சே சுல்தானகம் (Aceh Sultanate,"

@Tor:
Can you help? Seems WIN specific.
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Björn Michaelsen 2011-12-23 13:26:26 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 6 Rainer Bielefeld Retired 2012-01-23 09:47:41 UTC
@Mayooresan
That sounds as if WIN LibO is more or less unusable for Tamil texts?
Comment 7 Rainer Bielefeld Retired 2012-01-29 02:27:57 UTC
This problem is a part of the more general "Bug 45355 - CRASH if characters in text of BENGALI, TIBETAN, MALAYALAM, MARATHI, NEPALI, TAMIL, TELUGU"

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 45355 ***