Download it now!
Bug 41075 - Base forms uses inappropriate default view
Summary: Base forms uses inappropriate default view
Status: RESOLVED DUPLICATE of bug 37024
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-21 02:41 UTC by dolgener
Modified: 2011-12-12 23:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Database showing incorrect form view (159.49 KB, application/vnd.sun.xml.base)
2011-11-10 10:59 UTC, Steven Shelton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dolgener 2011-09-21 02:41:46 UTC
Apparently since version 3.4, Base opens forms in page (uno:PrintLayout), no more in web layot (.uno:BrowseView). This renders most existing forms unusable!
Morover, apparently there is _no_ way to programmatically switch the view mode (especially
 
	dim args1(0) as new com.sun.star.beans.PropertyValue
	args1(0).Name = "BrowseView"
	args1(0).Value = true
	dispatcher.executeDispatch(document, ".uno:BrowseView", "", 0, args1())

does NOT work). The only workaround is to open a form in edit mode, then toggle edit mode off. However, that's no long-term solution.
Comment 1 Steven Shelton 2011-11-10 10:59:23 UTC
Created attachment 53378 [details]
Database showing incorrect form view
Comment 2 Steven Shelton 2011-11-10 11:00:27 UTC
I should also add this, on the 3.4.4 release:

The switching of views does not stick. For instance, I can open a form in a database and it will default to "print" view. All forms in the database will use this view. If I then edit any of the forms and put it into web view, the rest of the forms will show up in web view. HOWEVER . . . after I close out of LibO and re-open the file, everything goes back to print view again.

This is on Win XP (32-bit).

Example file attached.
Comment 3 Steven Shelton 2011-11-10 11:02:55 UTC
Also, sometimes it just causes LibO to crash when you try to switch views.
Comment 4 Dan Lucier 2011-12-12 08:22:13 UTC
I am having this exact same problem using LibO 3.4.4 in both Linux Mint 12 and Windows XP. 

All of my forms open in Print View. If I edit one of the forms, I can change it to Web View and save. Then when I reopen a form, it opens in Web View, but after I close the database, my view change is lost.
Comment 5 Zoltán Reizinger 2011-12-12 23:53:06 UTC
Duplicate of bug 37024.

*** This bug has been marked as a duplicate of bug 37024 ***