Bug Hunting Session
Bug 41111 - FORMATTING - superscripting is lost in the auto-created table of contents
Summary: FORMATTING - superscripting is lost in the auto-created table of contents
Status: RESOLVED DUPLICATE of bug 30732
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-22 04:30 UTC by Bob Dowling
Modified: 2014-05-17 10:25 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
trivially small superscript bug demonstration file (ODT) (9.93 KB, application/vnd.oasis.opendocument.text)
2011-09-22 04:30 UTC, Bob Dowling
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Dowling 2011-09-22 04:30:17 UTC
Created attachment 51515 [details]
trivially small superscript bug demonstration file (ODT)

1. Create a heading with a superscript in it. Mine is ∇2φ with the 2 as a superscript.

2. Create a Table of Contents. Insert→Indexes & tables.

3. Note that the "del squared phi" now reads "del two phi".

Example file attached.


Details of platform:
Software: LibreOffice 3.4.3 OOO340m1 (Build:302)
Operating system: openSUSE 11.4 (x86_64)
uname data: Linux noether 2.6.37.6-0.7-desktop #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Björn Michaelsen 2011-12-23 12:35:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Bob Dowling 2012-01-03 08:06:40 UTC
Bug persists in 3.5.0b2 .
Comment 3 A (Andy) 2013-05-03 21:12:01 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 4 Tobias Lippert 2014-05-17 10:25:43 UTC
This has already been reported a couple of years ago. I will submit a patch for this in about a month.

I am currently retaining sub- and superscript as well as italics. Is there anything more that should be applied to the table of contents from your point of view?

*** This bug has been marked as a duplicate of bug 30732 ***