Bug Hunting Session
Bug 41136 - EDITING: text selection with mouse impossible in front of background image
Summary: EDITING: text selection with mouse impossible in front of background image
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-22 19:51 UTC by Jay
Modified: 2011-09-23 10:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document, see Comment 1 (98.36 KB, application/vnd.oasis.opendocument.text)
2011-09-22 23:04 UTC, Rainer Bielefeld Retired
Details
Sample document with background image and text (10.49 KB, application/vnd.oasis.opendocument.text)
2011-09-23 10:31 UTC, Jay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jay 2011-09-22 19:51:20 UTC
Add a background image to the page; select it and pick Send to Back.  Wrap in Background, Anchor to Page.

Add text to the text area of the page.

Selecting text is often extremely difficult, because even though you click on the text, the background image is selected.  When with great difficulty I am able to get a cursor in the text, it is often only for a read-only selection.  Typing text produces no results, and pressing the arrow keys do not move the cursor around.
Comment 1 Rainer Bielefeld Retired 2011-09-22 23:03:40 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". Steps to reporduce:

1. Open attached "sample.odt"
2. Double click the first word of the text (or an other one far away from the 
   background image)
   As expected the complete word will be selected
3. Double click a word of the text in front of the background image
   Expected: als in step 2
   Actual: no selection. All other selection sith pushed mouse button do not
           work

Works fine with  Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]".

So the problem seems to have been fixed for the master.
Comment 2 Rainer Bielefeld Retired 2011-09-22 23:04:46 UTC
Created attachment 51533 [details]
Sample Document, see Comment 1
Comment 3 Jay 2011-09-23 10:31:22 UTC
Created attachment 51554 [details]
Sample document with background image and text

Try clicking in different spots in the text and editing, it is very difficult.