Download it now!
Bug 41161 - VIEWING: Improper Layout of elements in mbedded forms
Summary: VIEWING: Improper Layout of elements in mbedded forms
Status: RESOLVED DUPLICATE of bug 37024
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-23 16:03 UTC by Drew Jensen
Modified: 2011-09-26 09:37 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
test file (328.79 KB, application/vnd.sun.xml.base)
2011-09-23 16:04 UTC, Drew Jensen
Details
Screen shot of test forum opned with LibO 3.4.3 (108.29 KB, image/png)
2011-09-23 16:09 UTC, Drew Jensen
Details
Screen shot of test form opened with LibO 3.3.3 (106.52 KB, image/png)
2011-09-23 16:10 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2011-09-23 16:03:09 UTC
Test system - LibO 3.4.3 (from TDF download) and LibO 3.3.3 (Ubuntu Repsotory), Ubuntu Studio 11.04 64bit, Gnome desktop.

Opening embedded forms in ODB files created with OO.o 3.1 with LibO 3.4.3 renders incorrect (badly) layout of the UI elements. 

Doing so with LbO 3.3.3 does not have the same problems.

Currently I've only checked this with a few odb files originally created and last edited with OO.o 3.0 - haven not checked if forms created with Libo 3.4.3 do or do not have the problems - but expect so (see next Issue)

Steps to reproduce:
Open attached odb file
Expand the folder MSIS
Open the form frmInvoiceHead (though most any will do)



Current behavior:
See screen shot attached from 3.4.3

Expected behavior:
see screen shot attached from 3.3.3
Comment 1 Drew Jensen 2011-09-23 16:04:35 UTC
Created attachment 51556 [details]
test file
Comment 2 Drew Jensen 2011-09-23 16:09:59 UTC
Created attachment 51557 [details]
Screen shot of test forum opned with LibO 3.4.3
Comment 3 Drew Jensen 2011-09-23 16:10:42 UTC
Created attachment 51558 [details]
Screen shot of test form opened with LibO 3.3.3
Comment 4 Drew Jensen 2011-09-23 16:21:06 UTC
Actually I mentioned a next issue in the earlier comments - but maybe not - it really looks, to me, that the issue just that the View setting for the ODT file (as form) is set to print and not web.

also - the Page>Format menu item is active under 3.4.3, which it shouldn't be. I was going to open that as a separate issue, and if will if you want, but perhaps that is tied close enough to this issue so as to be not needed.
Comment 5 Drew Jensen 2011-09-26 09:37:19 UTC

*** This bug has been marked as a duplicate of bug 37024 ***